diff mbox series

[bug#60663] gnu: linux-libre: Update to 6.1.

Message ID 9e1dca67d7df944f97f56ce4f8df3f1d56cd78ff.1673211055.git.leo@famulari.name
State New
Headers show
Series [bug#60663] gnu: linux-libre: Update to 6.1. | expand

Commit Message

Leo Famulari Jan. 8, 2023, 8:50 p.m. UTC
* gnu/packages/linux.scm (linux-libre-version, linux-libre-gnu-revision,
linux-libre-pristine-source, linux-libre-source, linux-libre): Use linux-libre
6.1.
---
 gnu/packages/linux.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

Maxim Cournoyer Jan. 11, 2023, 7:17 p.m. UTC | #1
Hi Leo,

Leo Famulari <leo@famulari.name> writes:

> * gnu/packages/linux.scm (linux-libre-version, linux-libre-gnu-revision,
> linux-libre-pristine-source, linux-libre-source, linux-libre): Use linux-libre
> 6.1.
> ---
>  gnu/packages/linux.scm | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 516f8c8507..933af66904 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -1089,11 +1089,11 @@ (define-public linux-libre-6.0
>                         "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
>                       #:configuration-file kernel-config))
>  
> -(define-public linux-libre-version         linux-libre-6.0-version)
> -(define-public linux-libre-gnu-revision    linux-libre-6.0-gnu-revision)
> -(define-public linux-libre-pristine-source linux-libre-6.0-pristine-source)
> -(define-public linux-libre-source          linux-libre-6.0-source)
> -(define-public linux-libre                 linux-libre-6.0)
> +(define-public linux-libre-version         linux-libre-6.1-version)
> +(define-public linux-libre-gnu-revision    linux-libre-6.1-gnu-revision)
> +(define-public linux-libre-pristine-source linux-libre-6.1-pristine-source)
> +(define-public linux-libre-source          linux-libre-6.1-source)
> +(define-public linux-libre                 linux-libre-6.1)

I get from this that the pristine source and deblob scripts had already
been added?

What about the changes to the kconfig files; don't they change between
releases?
Leo Famulari Jan. 12, 2023, 1:03 a.m. UTC | #2
On Wed, Jan 11, 2023 at 02:17:06PM -0500, Maxim Cournoyer wrote:
> I get from this that the pristine source and deblob scripts had already
> been added?
> 
> What about the changes to the kconfig files; don't they change between
> releases?

Linux-libre 6.1, and everything that's necessary to use it, was added in
commit cfce55bf4f232791f4341665a01c4cb873f0f60d

This patch would make it the default version.
Maxim Cournoyer Jan. 12, 2023, 2:46 a.m. UTC | #3
Hi,

Leo Famulari <leo@famulari.name> writes:

> On Wed, Jan 11, 2023 at 02:17:06PM -0500, Maxim Cournoyer wrote:
>> I get from this that the pristine source and deblob scripts had already
>> been added?
>> 
>> What about the changes to the kconfig files; don't they change between
>> releases?
>
> Linux-libre 6.1, and everything that's necessary to use it, was added in
> commit cfce55bf4f232791f4341665a01c4cb873f0f60d
>
> This patch would make it the default version.

Thanks for bringing me up to speed.

I'm stuck on using 5.15 myself due to #59361, so can't comment on the
well functioning of linux-libre 6.1 just yet, but I trust that it
should, so unless someone else saw issues using it, I think you can go
ahead and apply the change.
Leo Famulari Jan. 13, 2023, 5:49 a.m. UTC | #4
On Wed, Jan 11, 2023 at 09:46:29PM -0500, Maxim Cournoyer wrote:
> I'm stuck on using 5.15 myself due to #59361, so can't comment on the
> well functioning of linux-libre 6.1 just yet, but I trust that it
> should, so unless someone else saw issues using it, I think you can go
> ahead and apply the change.

Okay, pushed as ce8a34bc9ab89f31f107383ba791954864aed372

Do you know if #59361 has been reported upstream?
Maxim Cournoyer Jan. 13, 2023, 6:20 p.m. UTC | #5
Hi,

Leo Famulari <leo@famulari.name> writes:

> On Wed, Jan 11, 2023 at 09:46:29PM -0500, Maxim Cournoyer wrote:
>> I'm stuck on using 5.15 myself due to #59361, so can't comment on the
>> well functioning of linux-libre 6.1 just yet, but I trust that it
>> should, so unless someone else saw issues using it, I think you can go
>> ahead and apply the change.
>
> Okay, pushed as ce8a34bc9ab89f31f107383ba791954864aed372
>
> Do you know if #59361 has been reported upstream?

Yes, I've even bisected it and found the commit responsible for it [0],
but it seems to affect only my particular version of that card, so it's
niche and unlikely to gather much interest.  There's also some details
on how I proceded to do the regression tests at
https://issues.guix.gnu.org/59361

[0] https://gitlab.freedesktop.org/drm/nouveau/-/issues/192
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 516f8c8507..933af66904 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1089,11 +1089,11 @@  (define-public linux-libre-6.0
                        "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
                      #:configuration-file kernel-config))
 
-(define-public linux-libre-version         linux-libre-6.0-version)
-(define-public linux-libre-gnu-revision    linux-libre-6.0-gnu-revision)
-(define-public linux-libre-pristine-source linux-libre-6.0-pristine-source)
-(define-public linux-libre-source          linux-libre-6.0-source)
-(define-public linux-libre                 linux-libre-6.0)
+(define-public linux-libre-version         linux-libre-6.1-version)
+(define-public linux-libre-gnu-revision    linux-libre-6.1-gnu-revision)
+(define-public linux-libre-pristine-source linux-libre-6.1-pristine-source)
+(define-public linux-libre-source          linux-libre-6.1-source)
+(define-public linux-libre                 linux-libre-6.1)
 
 (define-public linux-libre-5.15
   (make-linux-libre* linux-libre-5.15-version