diff mbox series

[bug#73118,v2,2/5] gnu: make-libstdc++-arm-none-eabi: output libstdc++ to arm-none-eabi.

Message ID 9db92cc94fd199a5b640a30a1e62c5e2b023df66.1726227323.git.rutherther@protonmail.com
State New
Headers show
Series Fix arm-none-eabi toolchains and introduce a newer version 12.3.rel1 | expand

Commit Message

Rutherther Sept. 13, 2024, 11:42 a.m. UTC
The libstdc++ made for arm-none-eabi puts the contents
into "lib" folder, but that's unexpected when the resulting
toolchain is a cross toolchain.
The folder should be "arm-none-eabi/lib", that's the path
added to CROSS_C_LIBRARY_PATH

* gnu/packages/embedded.scm (make-libstdc++-arm-none-eabi):
[arguments]<#:configure-flags>: Point --libdir to arm-none-eabi/lib.
[arguments]<#:strip-directories>: Set to arm-none-eabi/lib.

Change-Id: Ia8b867a1c6ebeedeae9564e0a6a1e0401b35bd5b
---
 gnu/packages/embedded.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index a7ba9ebe98..2a482f7e52 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -493,9 +493,14 @@  (define make-libstdc++-arm-none-eabi
                "--disable-tls"
                "--disable-plugin"
                "--with-newlib"
+               ,(string-append "--libdir="
+                               (assoc-ref %outputs "out")
+                               "/arm-none-eabi/lib")
                ,(string-append "--with-gxx-include-dir="
                                (assoc-ref %outputs "out")
-                               "/arm-none-eabi/include/c++")))))
+                               "/arm-none-eabi/include/c++")))
+           ((#:strip-directories _ #f)
+            ''("arm-none-eabi/lib"))))
         (native-inputs
          `(("newlib" ,newlib)
            ("xgcc" ,xgcc)