diff mbox series

[bug#71266,2/2] gnu: python-identify: Update to 2.5.36

Message ID 9dad5899b80ac986e65c0af2dc6bdb91ea88b432.1717021909.git.noelopez@free.fr
State New
Headers show
Series Update pre-commit to 3.7.1 | expand

Commit Message

NoƩ Lopez May 29, 2024, 10:45 p.m. UTC
* gnu/packages/python-xyz.scm (python-identify): Update to 2.5.36

Change-Id: I040c7571fc69c194d98d89685e5d468092f515c0
---
 gnu/packages/python-xyz.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9d3066cab4..279ffd2ec6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27254,7 +27254,7 @@  (define-public python-requests-file
 (define-public python-identify
   (package
     (name "python-identify")
-    (version "1.4.25")
+    (version "2.5.36")
     (source
      (origin
        ;; There are no tests in the PyPI tarball.
@@ -27264,7 +27264,7 @@  (define-public python-identify
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1fqgci6skckcq0x5pnxh6k2qjzn1ndsrgha1j6wwv1ld4g9bd3hz"))))
+        (base32 "1il0d1zh31jx36m0lvhpiykx95i95dcfrgrfbz2x6la884zsmvq8"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -27274,7 +27274,9 @@  (define-public python-identify
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (invoke "pytest" "-vv")))))))
+               (invoke "pytest"
+                       "-k" "not test_license" ; dependency on ukkonen
+                       "-vv")))))))
     (native-inputs
      (list python-coverage python-pytest))
     (propagated-inputs