diff mbox series

[bug#71608,1/2] gnu: python-wtforms: Update to 3.1.2

Message ID 9d966393ba8af8e5a2ca5ec53b1edd053462e14e.1718606041.git.ben@sturm.com.au
State New
Headers show
Series Update python-wtforms (and add split out python-wtforms-sqlalchemy) | expand

Commit Message

Ben Sturmfels June 17, 2024, 6:49 a.m. UTC
* gnu/packages/python-web.scm (python-wtforms): Update to 3.1.2

Change-Id: Id8119d0536d4d2dfa5c81de37013af68489c5fa5
---
 gnu/packages/python-web.scm | 33 ++++++++-------------------------
 1 file changed, 8 insertions(+), 25 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5ca50fa5a6..fae4b8bf0f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5268,35 +5268,18 @@  (define-public python-bottle
 (define-public python-wtforms
   (package
     (name "python-wtforms")
-    (version "2.3.3")
+    (version "3.1.2")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "WTForms" version))
+       (uri (pypi-uri "wtforms" version))
        (sha256
-        (base32
-         "17427m7p9nn9byzva697dkykykwcp2br3bxvi8vciywlmkh5s6c1"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'delete-bundled-test
-           (lambda _
-             ;; Delete test copied from a third party package that fails
-             ;; with newer SQLAlchemy.  This can be removed for 3.0.
-             ;; See <https://github.com/wtforms/wtforms/issues/696>.
-             (delete-file "tests/ext_sqlalchemy.py")))
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "python" "setup.py" "compile_catalog")
-               (invoke "python" "tests/runtests.py")))))))
-    (native-inputs
-     (list python-dateutil python-sqlalchemy))
-    (propagated-inputs
-     (list python-babel python-email-validator python-markupsafe))
-    (home-page "http://wtforms.simplecodes.com/")
+        (base32 "1fblnkzvs6339glwx8bskdjy7nhn2ap90y9g6b399713sy063mzq"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-hatchling python-pytest))
+    (propagated-inputs (list python-babel python-email-validator
+                             python-markupsafe))
+    (home-page "https://wtforms.readthedocs.io/")
     (synopsis
      "Form validation and rendering library for Python web development")
     (description