diff mbox series

[bug#42454] gnu: enigma: Fix enigma.

Message ID 9d761881-01d7-7ac3-92a1-32ec5e63d47a@gmail.com
State Accepted
Headers show
Series [bug#42454] gnu: enigma: Fix enigma. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jesse Gibbons July 21, 2020, 6:07 a.m. UTC
* gnu/packages/games.scm: enigma(phases): Add 'fix-proxy.
---
gnu/packages/games.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)

Comments

Brett Gilio July 25, 2020, 1:21 a.m. UTC | #1
Jesse Gibbons <jgibbons2357@gmail.com> writes:

> * gnu/packages/games.scm: enigma(phases): Add 'fix-proxy.
> ---
> gnu/packages/games.scm | 12 +++++++++++-
> 1 file changed, 11 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 2efbb3964e..14d47dcbe6 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -5872,7 +5872,17 @@ The Flag. You can even design your own maps!")
> (substitute* "src/main.cc"
> (("#include <SDL_(image|ttf|mixer).h>" line header)
> (string-append "#include \"SDL/SDL_" header ".h\"")))
> - #t)))))
> + #t))
> + (add-after 'find-sdl 'fix-proxy
> + (lambda _
> + ;; Build fails when making src/lev/Proxy.cc because
> + ;; the wrong operator overload is used.
> + (substitute* "src/lev/Proxy.cc"
> + (("ifs != NULL")
> + "!ifs"))
> + (display "...")
> + #t))
> + )))
> (inputs
> `(("xerces-c" ,xerces-c)
> ("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))

Hey Jesse,

Just like the last patch this one is mangled :).
Jesse Gibbons Aug. 17, 2020, 9:01 p.m. UTC | #2
This is a friendly bump.

https://lists.gnu.org/archive/html/guix-patches/2020-07/msg00845.html
Efraim Flashner Aug. 19, 2020, 6:54 a.m. UTC | #3
It looks like a similar patch was pushed on July 24.
0b95f51eae50fbe627a354f50fa053a6d52b81aa
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2efbb3964e..14d47dcbe6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5872,7 +5872,17 @@  The Flag. You can even design your own maps!")
(substitute* "src/main.cc"
(("#include <SDL_(image|ttf|mixer).h>" line header)
(string-append "#include \"SDL/SDL_" header ".h\"")))
- #t)))))
+ #t))
+ (add-after 'find-sdl 'fix-proxy
+ (lambda _
+ ;; Build fails when making src/lev/Proxy.cc because
+ ;; the wrong operator overload is used.
+ (substitute* "src/lev/Proxy.cc"
+ (("ifs != NULL")
+ "!ifs"))
+ (display "...")
+ #t))
+ )))
(inputs
`(("xerces-c" ,xerces-c)
("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))