[bug#76746,v2,06/13] gnu: Add python-jaconv.
Commit Message
* gnu/packages/python-xyz.scm (python-jaconv): New variable.
Change-Id: I0b29cd00f311ae2a4dbb2c8f59148fc4bbadc144
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
@@ -34499,6 +34499,28 @@ (define-public python-flufl-i18n
different tasks.")
(license license:asl2.0)))
+(define-public python-jaconv
+ (package
+ (name "python-jaconv")
+ (version "0.3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ikegami-yukino/jaconv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pfx0zvyz07c1jywrv5ayklpmjz91mrb62gc52g48d4qnqwa3fzn"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (home-page "https://github.com/ikegami-yukino/jaconv")
+ (synopsis "Python Japanese character interconverter")
+ (description
+ "@code{jaconv} (Japanese Converter) is an interconverter for Hiragana,
+Katakana, Hankaku (half-width character) and Zenkaku (full-width character)")
+ (license license:expat)))
+
(define-public python-flufl-lock
(package
(name "python-flufl-lock")