diff mbox series

[bug#64199] gnu: Add firejail.

Message ID 9d5b11ec067f815f252235b8d67050a865b98727.1687308888.git.kiasoc5@disroot.org
State New
Headers show
Series [bug#64199] gnu: Add firejail. | expand

Commit Message

kiasoc5 June 21, 2023, 12:54 a.m. UTC
Firejail compiles ok, but I'm currently unable to test this on Guix system, so I don't know if any other patching is required to make it work as expected.

* gnu/packages/linux.scm (firejail): New variable.
---
 gnu/packages/linux.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 1a0ff5cd83d3257efcab64740a1322de51fbc4a1
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 52fb883467..fe22412fbc 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -10135,6 +10135,35 @@  (define-public kconfig-hardened-check
 This tool supports checking Kconfig options and kernel cmdline parameters.")
     (license license:gpl3)))
 
+(define-public firejail
+  (package
+    (name "firejail")
+    (version "0.9.72")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/netblue30/firejail/releases/download/" version
+                                  "/firejail-" version
+                                  ".tar.xz" ))
+              (sha256
+               (base32
+                "1x77xy1mwfgjrcsymdda82bjnqgl7z2yymcb10mzd1zwik27gqc2"))))
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (with-directory-excursion "test"
+                       (invoke "make"))))))))
+    (build-system gnu-build-system)
+    (inputs
+     (list apparmor xdg-dbus-proxy))
+    (synopsis "Linux namespaces sandbox program")
+    (description
+     "Firejail is a SUID sandbox program that reduces the risk of security breaches by restricting the running environment of untrusted applications using Linux namespaces, seccomp-bpf and Linux capabilities.  The software includes sandbox profiles for a number of common Linux programs.  Firejail should be added to the list of setuid programs in the system configuration to work properly.")
+    (home-page "https://github.com/netblue30/firejail")
+    (license license:gpl2)))
+
 (define-public edac-utils
   (package
     (name "edac-utils")