diff mbox series

[bug#38459] gnu: (cross-gcc-arguments|gcc-boot0): Enable 128 bit long double for POWER9.

Message ID 9d5aee30-1cfe-434b-f191-3bbd06caa319@free.fr
State Accepted
Headers show
Series [bug#38459] gnu: (cross-gcc-arguments|gcc-boot0): Enable 128 bit long double for POWER9. | expand

Commit Message

dftxbs3e Dec. 2, 2019, 7:20 p.m. UTC
Hello,

This is to be applied against core-updates and fixes:

$ guix build --target=powerpc64le-linux-gnu bootstrap-tarballs

dftxbs3e

Comments

vasilii.smirnov--- via Guix-patches" via Dec. 2, 2019, 7:57 p.m. UTC | #1
dftxbs3e,

dftxbs3e 写道:
> This is to be applied against core-updates and fixes:
>
> $ guix build --target=powerpc64le-linux-gnu bootstrap-tarballs

Thanks for sending this in!  I'll be sure to merge it if no one 
else has objections.

I'm really not familiar with this part of Guix, though.  I'd 
naively expect this to be guarded with an (if …) so it only 
applies to POWER.  (Why) is that not possible or desirable?

Kind regards,

T G-R
dftxbs3e Dec. 2, 2019, 8:03 p.m. UTC | #2
Yes, it should certainly be guarded by an if to avoid breaking other 
platforms, even if it shouldnt hurt much.

Issue is I do not know Scheme enough to figure out the syntax for an 
inline if like that. So I would appreciate if you could help me on that?

On 12/2/19 8:57 PM, Tobias Geerinckx-Rice via Guix-patches via wrote:
> dftxbs3e,
>
> dftxbs3e 写道:
>> This is to be applied against core-updates and fixes:
>>
>> $ guix build --target=powerpc64le-linux-gnu bootstrap-tarballs
>
> Thanks for sending this in!  I'll be sure to merge it if no one else 
> has objections.
>
> I'm really not familiar with this part of Guix, though.  I'd naively 
> expect this to be guarded with an (if …) so it only applies to POWER.  
> (Why) is that not possible or desirable?
>
> Kind regards,
>
> T G-R
dftxbs3e Nov. 20, 2020, 11:30 p.m. UTC | #3
Note: this can be applied on master by now since core-updates was
merged into it since then.
diff mbox series

Patch

From 87b30dcb90572bd46c8eb087efe7d75db362f59b Mon Sep 17 00:00:00 2001
From: dftxbs3e <dftxbs3e@free.fr>
Date: Mon, 2 Dec 2019 19:58:19 +0100
Subject: [PATCH 1/2] gnu: gcc-boot0: Enable 128 bit long double for POWER9.

---
 gnu/packages/commencement.scm | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 8bf7704598..bfdba4dbd2 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1576,6 +1576,9 @@  exec " gcc "/bin/" program
                            "--disable-shared"
                            "--enable-languages=c,c++"
 
+                           ;; On POWER9 (little endian) glibc needs the 128 bit long double type.
+                           "--with-long-double-128"
+
                            ;; libstdc++ cannot be built at this stage
                            ;; ("Link tests are not allowed after
                            ;; GCC_NO_EXECUTABLES.").
-- 
2.21.0