diff mbox series

[bug#67211] gnu: Add emacs-adwaita-dark-theme

Message ID 9d33e4f09468d48a77db6c2dac38e25ff1fb9001.1700084634.git.tristan@cott.am
State New
Headers show
Series [bug#67211] gnu: Add emacs-adwaita-dark-theme | expand

Commit Message

Tristan Cottam Nov. 15, 2023, 9:43 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-adwaita-dark-theme): New variable.

Change-Id: Id6e6d0d6aa27e7c1cc6ec0fc11c3a5f09231d751
---

> FWIW, changing the Version keyword in the header is a release. Also, it
> has the benefit of making the version number more meaningful.

I agree, I had missed that version bump commit. However, it isn't in fact the
last one, so I left the rest as it is.

 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: bd0f2173210416e86281c1de8789e7cdab66dd57
prerequisite-patch-id: 5e36e77f4fa1848dbd20c2e5d5cec31d2473c2a8

Comments

Nicolas Goaziou Nov. 16, 2023, 11:58 a.m. UTC | #1
Hello,

Tristan Cottam via Guix-patches via <guix-patches@gnu.org> writes:

> I agree, I had missed that version bump commit. However, it isn't in fact the
> last one, so I left the rest as it is.

My point is that is it usually better to package version bumps rather
than arbitrary commits. IOW, I'd rather drop the revision and package
057c39313341907b35c68d2179226886a0c276fd instead.

> +      (description
> +       "adwaita-dark-theme is an Adwaita-inspired dark color scheme for
> +Emacs.")

You didn't change this. Is it intentional?

Regards,
Tristan Cottam Nov. 16, 2023, 3:38 p.m. UTC | #2
I accidentally sent a reply to #67198 to guix-patches@gnu.org, resulting in
this new issue. How can I close this?
Nicolas Goaziou Nov. 16, 2023, 7:57 p.m. UTC | #3
Hello,

Tristan Cottam via Guix-patches via <guix-patches@gnu.org> writes:

> I accidentally sent a reply to #67198 to guix-patches@gnu.org, resulting in
> this new issue. How can I close this?

You can send an empty mail to <NNN-done@debbugs.gnu.org> where NNN is
the number of the issue you created.

Regards,
Tristan Cottam Nov. 16, 2023, 8:35 p.m. UTC | #4
> You can send an empty mail to <NNN-done@debbugs.gnu.org> where NNN is
> the number of the issue you created.

Great, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index be7ffd1f37..443f315f23 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1995,6 +1995,29 @@  (define-public emacs-suneater-theme
 theme but now takes more inspiration from the Nano theme.")
     (license license:gpl3+)))
 
+(define-public emacs-adwaita-dark-theme
+  (let ((commit "a97d5d5f5657a52c3b4c4b146b4d307dfb1a7a74")
+        (revision "0"))
+    (package
+      (name "emacs-adwaita-dark-theme")
+      (version (git-version "1.1.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://gitlab.com/jessieh/adwaita-dark-theme")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0g8fjqmz805fhqspbzmpvb90kpzwigl4z56bkykywgy2cwb9ljzh"))))
+      (build-system emacs-build-system)
+      (home-page "https://gitlab.com/jessieh/adwaita-dark-theme")
+      (synopsis "Adwaita-inspired dark color scheme for Emacs")
+      (description
+       "adwaita-dark-theme is an Adwaita-inspired dark color scheme for
+Emacs.")
+      (license license:gpl2+))))
+
 (define-public emacs-treepy
   (package
     (name "emacs-treepy")