diff mbox series

[bug#65477,2/2] gnu: Add emacs-slite.

Message ID 9d1940eb5c8adfa295f690d451c04ec2beb3bb87.1692810936.git.mail@ykonai.net
State New
Headers show
Series Add emacs-slite | expand

Commit Message

ykonai Aug. 23, 2023, 5:48 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-slite): New variable.
---
 gnu/packages/emacs-xyz.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)

Comments

Ludovic Courtès Sept. 17, 2023, 1:30 p.m. UTC | #1
Hi,

ykonai <mail@ykonai.net> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-slite): New variable.

[...]

> +(define-public emacs-slite
> +  (package
> +    (inherit sbcl-slite)

Since ‘sbcl-slite’ is defined in lisp-xyz.scm, you should either define
‘emacs-slite’ in that same file or the other way around.

Could you send an updated patch?

Thanks,
Ludo’.
ykonai Sept. 27, 2023, 8:36 p.m. UTC | #2
Hi,

I moved it into the lisp-xyz.scm file. This required adding the emacs
build-system to the list of required modules in lisp-xyz.scm. Apologies
for the delay.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 977d553ea5..06682e2227 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9757,6 +9757,21 @@  (define-public emacs-slime
 for compilation, debugging, documentation lookup, and so on.")
     (license (list license:gpl2+ license:public-domain))))
 
+(define-public emacs-slite
+  (package
+    (inherit sbcl-slite)
+    (name "emacs-slite")
+    (build-system emacs-build-system)
+    (synopsis "SLIme-based TEst runner for FiveAM and Parachute Tests")
+    (description
+     "Slite interactively runs your Common Lisp tests (currently only FiveAM
+and Parachute are supported). It allows you to see the summary of test
+failures, jump to test definitions, rerun tests with debugger all from inside
+Emacs.
+
+In order to work, this also requires the slite Common Lisp system to be
+present. See the code@{*cl-slite packages}.")))
+
 (define-public emacs-popup
   (package
     (name "emacs-popup")