diff mbox series

[bug#69219,v2] gnu/packages/wm.scm(sandbar): New package definition.

Message ID 9cc6d22f07c41b69297791b8cee40d688b688daa.1711884784.git.erik@erikeduardo.xyz
State New
Headers show
Series [bug#69219,v2] gnu/packages/wm.scm(sandbar): New package definition. | expand

Commit Message

Erik Eduardo March 31, 2024, 11:33 a.m. UTC
Change-Id: I93f91436420a733a3b74d9b88ed5d69a9369ee38
---
 gnu/packages/wm.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: 0e8f7ee3a95011dd9ebdc99e0f3b754160524b5d

Comments

Nicolas Goaziou April 15, 2024, 10:19 a.m. UTC | #1
Hello,

Erik Eduardo <eduarskate8@gmail.com> writes:

> +(define-public sandbar

I normalized the commit message and applied your patch. Thank you.

> +    (description "@command{sandbar} is a minimalist DWM-like bar designed for River,
> +                 a Wayland compositor. It is triggered through commands sent via
> +                 standard input, providing extensive customization options. This
> +                 behavior allows users to dynamically adjust status text, visibility,
> +                 and bar location, making @command{sandbar} an ideal choice for those
> +                 seeking a lightweight and hackable bar solution in their Wayland
> +                 environment.")

I fixed indentation and separated sentences with two spaces.

Nitpick: I also used capitalization for Sandbar (the project name)
instead of @command{sandbar} (the command), as reducing markup is always
better for readability.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2aaf9b0f66..75a862fbe8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -69,6 +69,7 @@ 
 ;;; Copyright © 2024 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2024 Ahmad Draidi <a.r.draidi@redscript.org>
 ;;; Copyright © 2024 chris <chris@bumblehead.com>
+;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1384,6 +1385,42 @@  (define-public keybinder
 (define-public keybinder-3.0
   (deprecated-package "keybinder-3.0" keybinder))
 
+(define-public sandbar
+  (package
+    (name "sandbar")
+    (version "0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/kolunmi/sandbar")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0912cr2q2kg4nqdwy978kpmdcj2cjz3gnlcb28ny9z3cprxvyvxq"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+             (delete 'configure))  ;; no configure script
+           #:tests? #f             ;; no check target
+           #:make-flags
+           #~(list (string-append "CC=" #$(cc-for-target))
+                   (string-append "PREFIX=" #$output))))
+    (inputs (list fcft wayland))
+    (native-inputs (list pkg-config wayland-protocols))
+    (synopsis "DWM-like bar for the River Wayland compositor")
+    (description "@command{sandbar} is a minimalist DWM-like bar designed for River,
+                 a Wayland compositor. It is triggered through commands sent via
+                 standard input, providing extensive customization options. This
+                 behavior allows users to dynamically adjust status text, visibility,
+                 and bar location, making @command{sandbar} an ideal choice for those
+                 seeking a lightweight and hackable bar solution in their Wayland
+                 environment.")
+    ;;             LICENSE      LICENSE.dtao
+    (license (list license:gpl3 license:expat))
+    (home-page "https://github.com/kolunmi/sandbar")))
+
 (define-public spectrwm
   (package
     (name "spectrwm")