diff mbox series

[bug#56729,RFC,v3,08/32] gnu: Add python-lrcalc.

Message ID 9c66006374c6762e4702dd20d4e6aaa14f4aff1a.1685391447.git.guix@ikherbers.com
State New
Headers show
Series None | expand

Commit Message

vicvbcun May 29, 2023, 8:38 p.m. UTC
* gnu/packages/algebra.scm (python-lrcalc): New variable.
---
 gnu/packages/algebra.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index ba1131f358..3bc8ec7ab2 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1701,6 +1701,26 @@  (define-public lrcalc
     (license license:gpl2+)
     (home-page "https://sites.math.rutgers.edu/~asbuch/lrcalc/")))
 
+(define-public python-lrcalc
+  (package
+    (name "python-lrcalc")
+    (version "2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "lrcalc" version))
+              (sha256
+               (base32
+                "1adassfjalsdsngy01c37835qsx3gj0jx9cinc9b91x4xnd51873"))))
+    (build-system python-build-system)
+    (inputs (list lrcalc))
+    (native-inputs (list python-cython))
+    (home-page "https://sites.math.rutgers.edu/~asbuch/lrcalc/")
+    (synopsis "Python bindings for the Littlewood-Richardson Calculator")
+    (description
+     "This package provides a python interface to the Littlewood-Richardson
+Calculator library (lrcalc).")
+    (license license:gpl3+)))
+
 (define-public iml
   (package
     (name "iml")