diff mbox series

[bug#70306,v2] gnu: soqt: Update to 1.6.2.

Message ID 9bf8f238a8ce21bb742148b899c25b5852823010.1712833223.git.jean@foundation.xyz
State New
Headers show
Series [bug#70306,v2] gnu: soqt: Update to 1.6.2. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 11, 2024, 11 a.m. UTC
* gnu/packages/qt.scm (soqt): Update to 1.6.2.

Change-Id: Ie4c9f0c4cff7584801952cc561f4d6fa3515d0ec
---
 gnu/packages/qt.scm | 48 ++++++++++++++++++++++-----------------------
 1 file changed, 23 insertions(+), 25 deletions(-)


base-commit: 4e7337536ba41e888a601c92fada8a4adca9d2c6

Comments

Maxim Cournoyer April 28, 2024, 2:41 p.m. UTC | #1
Hi,

Jean-Pierre De Jesus DIAZ <jean@foundation.xyz> writes:

> * gnu/packages/qt.scm (soqt): Update to 1.6.2.

Applied!
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 13af841455..9a42ff36ee 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -5096,33 +5096,31 @@  (define-public qthttpserver
     (license license:gpl3+)))
 
 (define-public soqt
-  (let ((commit-ref "fb8f655632bb9c9c60e0ff9fa69a5ba22d3ff99d")
-        (revision "1"))
-    (package
-    (name "soqt")
-    (version (git-version "1.6.0" revision commit-ref))
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/coin3d/soqt")
-               (commit commit-ref)
-               (recursive? #t)))
-        (file-name (git-file-name name version))
-        (sha256
-          (base32 "16vikb3fy8rmk10sg5g0gy2c343hi3x7zccsga90ssnkzpq6m032"))))
-    (build-system cmake-build-system)
-    (arguments '(#:tests? #f)) ; There are no tests
-    (native-inputs
-      (list pkg-config cmake))
-    (inputs
-      (list qtbase-5 coin3D))
-    (home-page "https://github.com/coin3d/soqt")
-    (synopsis "Qt GUI component toolkit library for Coin")
-    (description "SoQt is a Qt GUI component toolkit library for Coin.  It is
+  (package
+  (name "soqt")
+  (version "1.6.2")
+  (source
+   (origin
+     (method git-fetch)
+     (uri (git-reference
+            (url "https://github.com/coin3d/soqt")
+            (commit (string-append "v" version))
+            (recursive? #t)))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32 "0rsfc4wmghl9fr4bwh9rpzjwzsmx00k4ki5gyvy85nb4kbmr9dwv"))))
+  (build-system cmake-build-system)
+  (arguments '(#:tests? #f)) ; There are no tests
+  (native-inputs
+   (list pkg-config cmake))
+  (inputs
+   (list qtbase-5 coin3D))
+  (home-page "https://github.com/coin3d/soqt")
+  (synopsis "Qt GUI component toolkit library for Coin")
+  (description "SoQt is a Qt GUI component toolkit library for Coin.  It is
 also compatible with SGI and TGS Open Inventor, and the API is based on the API
 of the InventorXt GUI component toolkit.")
-    (license license:bsd-3))))
+  (license license:bsd-3)))
 
 (define-public libdbusmenu-qt
   (package