[bug#78468,2/2] gnu: mosquitto: Enable websockets support.
Commit Message
* gnu/packages/messaging.scm (mosquitto): Enable websockets support.
[arguments]: Specify configure flags.
[inputs]: Add libwebsockets-for-mosquitto.
Change-Id: Idf9f373770b786b1f839eaae9f0291d0e32ab38a
---
gnu/packages/messaging.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
@@ -45,6 +45,7 @@
;;; Copyright © 2024, 2025 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024, 2025 Igor Goryachev <igor@goryachev.org>
;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
+;;; Copyright © 2025 Evgeny Pisemsky <mail@pisemsky.site>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2964,7 +2965,11 @@ (define-public mosquitto
(sha256
(base32 "17c9gf2xncxsi3v8fbgq3abfyb84lyr18in0s1pbplmqmr6fimbs"))))
(build-system cmake-build-system)
- (inputs (list openssl libxslt))
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "-DWITH_WEBSOCKETS=ON")))
+ (inputs (list openssl libxslt libwebsockets-for-mosquitto))
(synopsis "Message broker")
(description
"This package provides Eclipse Mosquitto, a message broker