[bug#76882] gnu: wayland-protocols-next: Update to 1.41.
Commit Message
* gnu/packages/freedesktop.scm (wayland-protocols-next): Update to 1.41.
Change-Id: I18b5486a7d9e820af7208a6278de1d173127bfdc
---
gnu/packages/freedesktop.scm | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)
base-commit: 4538aa4acd199db7d7df1deb5e47b2ff6edb50f9
Comments
Hi,
While fd.o gitlab infrastructure in under migration, this patch could be tested by replacing:
(url "https://gitlab.freedesktop.org/wayland/wayland-protocols")
with:
(url "https://gitlab.com/freedesktop-sdk/mirrors/freedesktop/wayland/wayland-protocols.git")
HTH
Zheng Junjie <z572@z572.online> writes:
> * gnu/packages/freedesktop.scm (wayland-protocols-next): Update to 1.41.
>
> Change-Id: I18b5486a7d9e820af7208a6278de1d173127bfdc
> ---
> gnu/packages/freedesktop.scm | 13 +++++++------
> 1 file changed, 7 insertions(+), 6 deletions(-)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index 34dfe202296..0a178b22ef5 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -1544,15 +1544,16 @@ (define-public wayland-protocols-next
> (package
> (inherit wayland-protocols)
> (name "wayland-protocols-next")
> - (version "1.38")
> + (version "1.41")
> (source (origin
> - (method url-fetch)
> - (uri (string-append "https://gitlab.freedesktop.org/wayland/"
> - "wayland-protocols/-/releases/" version "/downloads/"
> - "wayland-protocols-" version ".tar.xz"))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.freedesktop.org/wayland/wayland-protocols")
> + (commit version)))
> + (file-name (git-file-name name version))
> (sha256
> (base32
> - "1ghxb0w7rbq3kdv9lhm1iwcjh6p3sx1gxb3crqh2p78m0ln2j5zz"))))))
> + "148wh3cw88pv1adbhmkr13ass2vznzpa03hc3f6hwmwfv4bjsdlr"))))))
>
> (define-public wayland-utils
> (package
>
> base-commit: 4538aa4acd199db7d7df1deb5e47b2ff6edb50f9
pushed, closing.
@@ -1544,15 +1544,16 @@ (define-public wayland-protocols-next
(package
(inherit wayland-protocols)
(name "wayland-protocols-next")
- (version "1.38")
+ (version "1.41")
(source (origin
- (method url-fetch)
- (uri (string-append "https://gitlab.freedesktop.org/wayland/"
- "wayland-protocols/-/releases/" version "/downloads/"
- "wayland-protocols-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/wayland/wayland-protocols")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1ghxb0w7rbq3kdv9lhm1iwcjh6p3sx1gxb3crqh2p78m0ln2j5zz"))))))
+ "148wh3cw88pv1adbhmkr13ass2vznzpa03hc3f6hwmwfv4bjsdlr"))))))
(define-public wayland-utils
(package