diff mbox series

[bug#38177] Add emacs-spacegray-theme.

Message ID 9b9d9c82-1a77-408b-8fcc-265a4da38223@www.fastmail.com
State Accepted
Headers show
Series [bug#38177] Add emacs-spacegray-theme. | expand

Commit Message

David Wilson Nov. 12, 2019, 2:28 p.m. UTC
Hi Guix!

This patch adds the Spacegray theme for Emacs. I've tested it in a profile locally and it loads up just fine. `guix lint' output is also clean.

Thanks!

David
diff mbox series

Patch

From 56974fb35273e3a65eaf864842da2be1a1edeaa0 Mon Sep 17 00:00:00 2001
From: David Wilson <david@daviwil.com>
Date: Mon, 11 Nov 2019 06:54:59 -0800
Subject: [PATCH] gnu: Add emacs-spacegray-theme.

* gnu/packages/emacs-xyz.scm (emacs-spacegray-theme) New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 52a22ccca5..0ff92f0780 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4881,6 +4881,30 @@  is to keep colors easily distinguishable, contrast enough and still pleasant
 for the eyes.")
     (license license:expat))) ; MIT license
 
+(define-public emacs-spacegray-theme
+  (let ((commit "9826265c2bceb2ebc1c5e16a45021da0253ace97")
+        (revision "0"))
+    (package
+      (name "emacs-spacegray-theme")
+      (version (git-version "0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/bruce/emacs-spacegray-theme.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0aplwmm17ypbns5blc4rf5rr6dasj0zp5ibykpfl43fh4bd8z89n"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/bruce/emacs-spacegray-theme")
+      (synopsis "Port of Sublime Text's Spacegray theme for Emacs")
+      (description
+       "@code{spacegray-theme} is an Emacs port of the Spacegray theme from
+Sublime Text.  It features a dark blue/gray background and soft blue, green,
+orange and red as accent colors.")
+      (license license:expat)))) ; MIT license
+
 (define-public emacs-2048-game
   (package
     (name "emacs-2048-game")
-- 
2.24.0