diff mbox series

[bug#68819,26/49] gnu: Add rust-wayrs-protocols-0.13.

Message ID 9b99e85e93fd86f5563b953351a31d366bf060ee.1706619962.git.herman@rimm.ee
State New
Headers show
Series Update i3status-rust to 0.32.3. | expand

Commit Message

Herman Rimm Jan. 30, 2024, 3:25 p.m. UTC
* gnu/packages/crates-graphics.scm (rust-wayrs-protocols-0.13): Add
variable.
---
 gnu/packages/crates-graphics.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 32fb19ada7..6cccd47729 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -5037,6 +5037,27 @@  (define-public rust-wayrs-proto-parser-2
 xml files.")
     (license license:expat)))
 
+(define-public rust-wayrs-protocols-0.13
+  (package
+    (name "rust-wayrs-protocols")
+    (version "0.13.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "wayrs-protocols" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1888h4wh3knjwh19v4y2gjpsv5j78c4vk08gls5f3aa1iryfpd7x"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-wayrs-client" ,rust-wayrs-client-1))))
+    (home-page "https://github.com/MaxVerevkin/wayrs")
+    (synopsis "Collection of Wayland protocols to use with wayrs-client")
+    (description
+     "This package provides a collection of Wayland protocols to use
+with wayrs-client")
+    (license license:expat)))
+
 (define-public rust-wayrs-scanner-0.13
   (package
     (name "rust-wayrs-scanner")