diff mbox series

[bug#47933] gnu: Add python-crcmod.

Message ID 9b937c12-c3cc-34af-aba3-694fa17770c6@gnu.org
State New
Headers show
Series [bug#47933] gnu: Add python-crcmod. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Roel Janssen April 21, 2021, 1:38 p.m. UTC
Hi Guix,

Here's a patch for python-crcmod.

Kind regards,
Roel Janssen

Comments

Simon Tournier Nov. 3, 2021, 10:09 a.m. UTC | #1
Hi Roel,

On Wed, 21 Apr 2021 at 15:38, Roel Janssen <roel@gnu.org> wrote:

>>From 61fbb10be87a4d52a8a2a1328102e8f9c41b8726 Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Wed, 21 Apr 2021 15:36:55 +0200
> Subject: [PATCH] gnu: Add python-crcmod.
>
> * gnu/packages/python-xyz.scm (python-crcmod): New variable.
> ---
>  gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)

I have not applied this patch myself but it LGTM.  If it builds and
“guix lint” does not report nothing blocking, feel free to push. :-)

Cheers,
simon
Jelle Licht May 29, 2023, 11:06 a.m. UTC | #2
zimoun <zimon.toutoune@gmail.com> writes:

> Hi Roel,
>
> On Wed, 21 Apr 2021 at 15:38, Roel Janssen <roel@gnu.org> wrote:
>
>>>>From 61fbb10be87a4d52a8a2a1328102e8f9c41b8726 Mon Sep 17 00:00:00 2001
>> From: Roel Janssen <roel@gnu.org>
>> Date: Wed, 21 Apr 2021 15:36:55 +0200
>> Subject: [PATCH] gnu: Add python-crcmod.
>>
>> * gnu/packages/python-xyz.scm (python-crcmod): New variable.
>> ---
>>  gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
>>  1 file changed, 19 insertions(+)
>
> I have not applied this patch myself but it LGTM.  If it builds and
> “guix lint” does not report nothing blocking, feel free to push. :-)
>
> Cheers,
> simon

Superseded by commit 36ea29115cd, which was merged into master recently.
Closing.
diff mbox series

Patch

From 61fbb10be87a4d52a8a2a1328102e8f9c41b8726 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Wed, 21 Apr 2021 15:36:55 +0200
Subject: [PATCH] gnu: Add python-crcmod.

* gnu/packages/python-xyz.scm (python-crcmod): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5cf0b61c68..823d82cea7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -355,6 +355,25 @@  implementation for the Telegram Bot API.")
 with Python's logging module that outputs records using terminal colors.")
     (license license:expat)))
 
+(define-public python-crcmod
+  (package
+    (name "python-crcmod")
+    (version "1.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "crcmod" version))
+              (sha256
+               (base32
+                "07k0hgr42vw2j92cln3klxka81f33knd7459cn3d8aszvfh52w6w"))))
+    (build-system python-build-system)
+    (home-page "http://crcmod.sourceforge.net/")
+    (synopsis "CRC generator for Python")
+    (description "The software in this package provides a Python module for
+generating objects that compute the Cyclic Redundancy Check (CRC). It includes
+a (optional) C extension for fast calculation, as well as a pure Python
+implementation.")
+    (license license:expat)))
+
 (define-public python-pyprind
   (package
     (name "python-pyprind")
-- 
2.31.1