diff mbox series

[bug#39739] Here is the patch updated

Message ID 9b5b3851902fa98a0f351ba41b0c956d9da5cf04.camel@korwin-zmijowski.fr
State Accepted
Headers show
Series [bug#39739] Here is the patch updated | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Jeremy Korwin-Zmijowski March 27, 2020, 2:54 p.m. UTC
Le jeudi 19 mars 2020 à 02:39 +0000, Kyle Meyer a écrit :
> Hi Jérémy,
> 
> Thanks for the update and for clarifying the license with the author.
> 
> Jeremy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr> writes:
> 
> > +;;; Copyright © 2020 Jérémy Korwin-Zmijowski <
> > jeremy@korwin-zmijowski.fr>
> 
> This has a trivial conflict with master (4a0399e277 at the time I
> applied it for testing).  That'd be easy for whoever eventually
> commits
> your patch to clean up, but, if you resend the patch for the other
> reasons I mention below, it'd be good to resolve it on your end by
> moving that to a newer base.
> 
> > +(define-public emacs-ac-geiser
> > +  (package
> > +    (name "emacs-ac-geiser")
> > +    (version "0.1")
> > +    (source
> > +     (origin
> 
> You should specify a `file-name' so that the directory in the store
> contains the package name.  Note that you can run `guix lint' to
> catch
> issues like these:
> 
>   $ pre-inst-env guix lint emacs-ac-geiser
>   gnu/packages/emacs-xyz.scm:21842:5: emacs-ac-geiser@0.1: the source
>   file name should contain the package name
> 
> > +       (uri (git-reference
> > +             (url "https://github.com/xiaohanyu/ac-geiser.git")
> > +             (commit "502d18a8a0bd4b5fdd495a99299ba2a632c5cd9a")))
> 
> This commit is a couple of commits after the v0.1 tag, so you can
> represent that with something like
> 
>   (let ((commit "abcdef...")
>         (revision "0"))
>     (package
>       ...
>       (version (git-version "0.1" revision commit))
>       (source
>        (origin
>          (uri (git-reference
>                (url "https://github.com/xiaohanyu/ac-geiser.git")
>                (commit "abcdef...")))
> 
> You can find a good number of examples in emacs-xyz.scm.
> 
> Because the author clarified the license in the next commit
> (93818c936ee7e2f1ba1b315578bde363a7d43d05), I think that'd be a good
> commit to use.
> 
> > +       (method git-fetch)
> > +       (sha256 (base32
> > "0h2kakb4f5hgzf5l2kpqngalcmc4402lkg1pvs88c8z4rqp2vfvz"))))
> 
> Formatting/consistency nit: Most packages put "(base32 ..." on a new
> line.  I think the same is true, to a lesser extent, for the value of
> propagated-inputs below.
> 
> > +    (build-system emacs-build-system)
> > +    (propagated-inputs `(("geiser" ,emacs-geiser)
> > +                         ("auto-complete" ,emacs-auto-complete)))
> > +    (synopsis "Auto-complete backend for geiser")
> > +    (description "Provides one auto-complete source for Scheme
> > projects using geiser.")
> > +    (license license:bsd-3)
> > +    (home-page "https://github.com/xiaohanyu/ac-geiser")))
> 
> Thanks!

Hey Kyle,

I hope this one can do the job !

As I see three commits after the 0.1 release, I valued revision to 3.

Take care.

Jérémy

Comments

Leo Famulari March 27, 2020, 8:47 p.m. UTC | #1
On Fri, Mar 27, 2020 at 03:54:56PM +0100, Jeremy Korwin-Zmijowski wrote:
> As I see three commits after the 0.1 release, I valued revision to 3.

The revision field refers to the Guix package revision [0]. It's up to
the patch author if we start at 0 or 1, though.

[0] See the manual section Version Numbers
Kyle Meyer March 28, 2020, 3:28 a.m. UTC | #2
Hi Jérémy,

Jeremy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr> writes:
> Hey Kyle,
>
> I hope this one can do the job !

After the last iteration you sent to address Leo's comment, the patch
looks good to me.

Thanks for the updates.
diff mbox series

Patch

From c0bfbdfd69ac89fd092ed51cd9bbb07c0e784136 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=A9r=C3=A9my=20Korwin-Zmijowski?=
 <jeremy@korwin-zmijowski.fr>
Date: Fri, 27 Mar 2020 15:49:53 +0100
Subject: [PATCH 1/1] gnu: Add emacs-ac-geiser. * gnu/packages/emacs-xyz.scm
 (emacs-ac-geiser): New variable.

---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5653796731..863432f939 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21774,3 +21775,27 @@  enables modal editing and composition of commands, too.  It combines ideas of
 other Editors like Vim or Kakoune and tries to align them with regular Emacs
 conventions.")
     (license license:gpl3+)))
+
+(define-public emacs-ac-geiser
+  (let ((commit "93818c936ee7e2f1ba1b315578bde363a7d43d05")
+        (revision "3"))
+    (package
+      (name "emacs-ac-geiser")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (uri (git-reference
+               (url "https://github.com/xiaohanyu/ac-geiser.git")
+               (commit commit)))
+         (method git-fetch)
+         (sha256
+          (base32 "00n2qa26yilaj837n1yp6lbqa4gf30nkkbvanl7m9ih7k48ssqmw"))
+         (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("geiser" ,emacs-geiser)
+         ("auto-complete" ,emacs-auto-complete)))
+      (synopsis "Auto-complete backend for geiser")
+      (description "Provides one auto-complete source for Scheme projects using geiser.")
+      (license license:bsd-3)
+      (home-page "https://github.com/xiaohanyu/ac-geiser"))))
-- 
2.25.2