[bug#34643,1/2] gnu: Add WireGuard.

Message ID 9b27f8b284f9f92f7bbc8c8edc7dbadd54a5035d.1551057302.git.leo@famulari.name
State Accepted
Headers show
Series [bug#34643,1/2] gnu: Add WireGuard. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Leo Famulari Feb. 25, 2019, 1:15 a.m. UTC
* gnu/packages/linux.scm (wireguard): New variable.
---
 gnu/packages/linux.scm | 50 +++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 49 insertions(+), 1 deletion(-)

Comments

Leo Famulari March 2, 2019, 12:33 a.m. UTC | #1
On Sun, Feb 24, 2019 at 08:15:02PM -0500, Leo Famulari wrote:
> * gnu/packages/linux.scm (wireguard): New variable.

I pushed a modified version of this patch as
7a0479bb7b8535acad2bf36c7a0b0498a1313422

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6463510eeb..983e335e30 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -19,7 +19,7 @@ 
 ;;; Copyright © 2016, 2018 Rene Saavedra <pacoon@protonmail.com>
 ;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
 ;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
-;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.com>
 ;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -5132,3 +5132,51 @@  the correct permissions and ownership, and then pack them up, or one would
 have to construct the archives directly, without using the archiver.")
     (home-page "http://freshmeat.sourceforge.net/projects/fakeroot")
     (license license:gpl3+)))
+
+(define-public wireguard
+  (package
+    (name "wireguard")
+    (version "0.0.20190123")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://git.zx2c4.com/WireGuard/snapshot/"
+                                  "WireGuard-" version ".tar.xz"))
+              (sha256
+               (base32
+                "16yzzy4i0z2zslmyr3kppkvkrxryzwdil6v270w9w5mg65v3rlgd"))))
+    (build-system gnu-build-system)
+    (outputs '("out" ; The WireGuard userspace tools
+               "kernel-patch")) ; A patch to build Linux with WireGuard support
+    (arguments
+     `(#:make-flags
+       (list "CC=gcc"
+             "WITH_BASHCOMPLETION=yes"
+             ;; Build and install the helper script wg-quick(8).
+             "WITH_WGQUICK=yes"
+             (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             (string-append "SYSCONFDIR=" (assoc-ref %outputs "out") "/etc"))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure) ; No ./configure script
+         (add-after 'unpack 'make-patch
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((output (assoc-ref outputs "kernel-patch"))
+                    (patch-file (string-append output "/wireguard.patch"))
+                    (patch-builder "./contrib/kernel-tree/create-patch.sh"))
+               (mkdir-p output)
+               ;; XXX Do this in Scheme?
+               (zero? (system (string-append "bash " patch-builder " > " patch-file)))
+               #t)))
+         (add-after 'make-patch 'chdir
+           (lambda _
+             (chdir "src/tools")
+             #t)))))
+    (inputs
+     `(("libmnl" ,libmnl)))
+    (home-page "https://www.wireguard.com/")
+    (synopsis "Tools for configuring WireGuard")
+    (description "This package provides the userspace tools for setting and
+retrieving configuration of WireGuard network tunnel interfaces, and a patch
+that can be applied to a Linux kernel source tree in order to build it with
+WireGuard support.")
+    (license license:gpl2)))