diff mbox series

[bug#66814,gnome-team,WIP,v2] gnu: at-spi2-core: Update to 2.48.4.

Message ID 9b1b828225740531672a3ae2cbe0420013dc931f.1698601268.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#66814,gnome-team,WIP,v2] gnu: at-spi2-core: Update to 2.48.4. | expand

Commit Message

Liliana Marie Prikler Oct. 23, 2023, 4:20 p.m. UTC
* gnu/packages/gtk.scm (at-spi2-core): Update to 2.48.4.
(at-spi2-core-with-documentation)[#:phases]: Adjust accordingly.
[native-inputs]: Remove docbook-xml-4.3 and gtk-doc/stable.
Add gi-docgen, python, and python-sphinx.

Change-Id: I3fc09c79f1ae5594fe9ad50e7212fbee11ce8a90
Co-authored-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
Hi Vivien,

your patch sadly caused the documentation build to fail.  Below is a
revised version that builds, albeit without tests.  The original package
is sadly written in a way that doesn't allow to easily disable tests,
but more importantly, the tests actually fail with the documentation
enabled.  We should investigate as to why that happens.

Cheers

 gnu/packages/gtk.scm | 28 +++++++++-------------------
 1 file changed, 9 insertions(+), 19 deletions(-)


base-commit: 2677bf985c0025d04ffdcff31763978b633dbc58
prerequisite-patch-id: 3931d81d2155eb6c9bc99ea2d6d31a88377eda1c
prerequisite-patch-id: 226444cea9d3b0974377ad049735cd82b44be03a
prerequisite-patch-id: 1a7bf978a65eaae43a37fb40be6b4882652afb60
prerequisite-patch-id: efd150ce5309a68704db0bf22f477e93f231c0a9
prerequisite-patch-id: 3e54a72abd9d3b8ba43db1579ba3d03ad9f09235
prerequisite-patch-id: b37777e77370089c61c3e0cf1e77726fda827839
prerequisite-patch-id: 6d3d08c2f7a78de0a37aa439eee13eb4b8617e64
prerequisite-patch-id: d9f3cae36515204c9ed3b95108e510c0f65191b5
prerequisite-patch-id: 3bc4d0d28f6888944494494aeeac006b9b6c4069
prerequisite-patch-id: 0c122ec94fb2c0f9a2b416880f95e38a86119ce3
prerequisite-patch-id: 5648fb1ad60f3b49ed5e7942942b6780eb088c15
prerequisite-patch-id: 1cb3f92d09106b3f6136a18103a32e1801eeba41
prerequisite-patch-id: e69edd73b93d50e3c4ce78ac07af21b8743df518
prerequisite-patch-id: 83c27d6e791400fbf76220dc02a883d798ab72b0
prerequisite-patch-id: b2c8766578b5aeb5d9b1ba1722db93e8040e6a7a
prerequisite-patch-id: d88a09d78da3fff7de925022f57b037dbdb7b114
prerequisite-patch-id: 5f72a047ed04a1a063b08904e6523212ce639bf2
prerequisite-patch-id: a6bbbc23395653f93da46ceebc2b065599978218
prerequisite-patch-id: ca443a72e9397405d895f633da92b048369ed8d2
prerequisite-patch-id: c779825b86ad4f937269a8995a1fcb162b7643b3
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 21a12689b7..c0435304b4 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -106,6 +106,7 @@  (define-module (gnu packages gtk)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages sphinx)
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages guile-xyz)
@@ -792,7 +793,7 @@  (define-public at-spi2-core
   (hidden-package
    (package
      (name "at-spi2-core")
-     (version "2.45.90")
+     (version "2.48.4")
      (source (origin
                (method url-fetch)
                (uri (string-append "mirror://gnome/sources/" name "/"
@@ -800,7 +801,7 @@  (define-public at-spi2-core
                                    name "-" version ".tar.xz"))
                (sha256
                 (base32
-                 "03dba3c6m3sfapkkbbgzvbi1qcmrrlppydxjjs1m8ds9qb9hl1g9"))))
+                 "05d5azffbglnvqzwk8ngg61jksm3brrwhmfpymsrccz8j8lv3v19"))))
      (build-system meson-build-system)
      (arguments
       (list
@@ -864,28 +865,17 @@  (define-public at-spi2-core-with-documentation
                 #$flags))
        ((#:phases phases)
         #~(modify-phases #$phases
+            (delete 'check)         ; XXX: dbus-daemon terminated by signal 11
             (add-after 'unpack 'set-documentation-path
               (lambda _
                 ;; Ensure that the cross-references point to the "doc" output.
-                (substitute* "doc/libatspi/meson.build"
-                  (("docpath =.*")
-                   (string-append "docpath = '" #$output:doc
-                                  "/share/gtk-doc/html'\n")))))
-            (add-before 'install 'prepare-doc-directory
-              (lambda _
-                (mkdir-p (string-append #$output:doc "/share"))))
-            #$@(if (%current-target-system)
-                   #~()
-                   #~((add-after 'install 'move-documentation
-                        (lambda _
-                          (copy-recursively
-                           (string-append #$output "/share/gtk-doc")
-                           (string-append #$output:doc "/share/gtk-doc"))
-                          (delete-file-recursively
-                           (string-append #$output "/share/gtk-doc"))))))))))
+                (substitute* "doc/meson.build"
+                  (("docs_dir =.*")
+                   (string-append "docs_dir = '" #$output:doc
+                                  "/share/doc'\n")))))))))
     (native-inputs
      (modify-inputs (package-native-inputs at-spi2-core)
-       (append docbook-xml-4.3 gtk-doc/stable)))
+       (append gi-docgen python python-sphinx)))
     (properties (alist-delete 'hidden?
                               (package-properties at-spi2-core)))))