diff mbox series

[bug#66372,v2] gnu: emacs-mastodon: Update to 1.0.5.

Message ID 9b0938f378b114fcddc4254c7df1def4ef6d3bbe.1696637656.git.me@fabionatali.com
State New
Headers show
Series [bug#66372,v2] gnu: emacs-mastodon: Update to 1.0.5. | expand

Commit Message

Fabio Natali Oct. 7, 2023, 12:14 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.5.
---
Hi,

Here's an updated version of the patch for Emacs Mastodon 1.0.5.

The commit hash has been updated to reflect a change in the upstream repository.

I've used `guix lint' and `guix style', which didn't seem to spot anything major.

Hopefully this looks good.

Thanks, cheers, Fabio.


 gnu/packages/emacs-xyz.scm | 62 ++++++++++++++++++--------------------
 1 file changed, 29 insertions(+), 33 deletions(-)


base-commit: add2a22ad7bcca2521432e3f486460138401d5a5
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cf1542955c..47bdc10685 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32827,40 +32827,36 @@  (define-public emacs-wc-mode
     (license license:gpl3+)))
 
 (define-public emacs-mastodon
-  ;; No release in ~1 year, hence this snapshot.
-  (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
-        (revision "1"))
-    (package
-      (name "emacs-mastodon")
-      (version (git-version "1.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://codeberg.org/martianh/mastodon.el")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
-      (build-system emacs-build-system)
-      (arguments
-       (list #:phases
-             #~(modify-phases %standard-phases
-                 ;; Move the source files to the top level, which is included in
-                 ;; the EMACSLOADPATH.
-                 (add-after 'unpack 'move-source-files
-                   (lambda _
-                     (let ((el-files (find-files "./lisp" ".*\\.el$")))
-                       (for-each (lambda (f)
-                                   (rename-file f (basename f)))
-                                 el-files)))))))
-      (propagated-inputs
-       (list emacs-request emacs-ts emacs-persist))
-      (home-page "https://codeberg.org/martianh/mastodon.el")
-      (synopsis "Emacs client for Mastodon")
-      (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+  (package
+    (name "emacs-mastodon")
+    (version "1.0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://codeberg.org/martianh/mastodon.el")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zjn3v3qfr034vz0ns7s9j7n4xzzqy5xiihc307mr3f6fcjgq0xd"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   ;; Move the source files to the top level, which is included in
+                   ;; the EMACSLOADPATH.
+                   (add-after 'unpack 'move-source-files
+                     (lambda _
+                       (let ((el-files (find-files "./lisp" ".*\\.el$")))
+                         (for-each (lambda (f)
+                                     (rename-file f
+                                                  (basename f))) el-files)))))))
+    (propagated-inputs (list emacs-request emacs-ts emacs-persist))
+    (home-page "https://codeberg.org/martianh/mastodon.el")
+    (synopsis "Emacs client for Mastodon")
+    (description "@code{mastodon.el} is an Emacs client for Mastodon, the
 federated microblogging social network.")
-	  (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-ebdb
   (package