diff mbox series

[bug#67943] gnu: linux: add wireplumber-minimal.

Message ID 9adaf00fe27bf406396f699ececc8d93@lyrion.ch
State New
Headers show
Series [bug#67943] gnu: linux: add wireplumber-minimal. | expand

Commit Message

Daniel Ziltener Dec. 20, 2023, 10:40 p.m. UTC
This inherits wireplumber, and removes the dependency on elogind to make it
useful for people using seatd.
---
 gnu/packages/linux.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

Comments

Hilton Chain Dec. 22, 2023, 2:32 p.m. UTC | #1
Hi Daniel,

On Thu, 21 Dec 2023 06:40:58 +0800,
Daniel Ziltener via Guix-patches via wrote:
>
> This inherits wireplumber, and removes the dependency on elogind to make it
> useful for people using seatd.
> ---
>  gnu/packages/linux.scm | 10 ++++++++++
>  1 file changed, 10 insertions(+)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 3ca756dead..999b9b4363 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -9451,6 +9451,16 @@ (define-public wireplumber
>  tools for managing PipeWire.")
>      (license license:expat)))
>
> +(define-public wireplumber-minimal
> +  (package
> +    (inherit wireplumber)
> +    (name "wireplumber-minimal")
> +    (arguments
> +     `(#:configure-flags '("-Dsystemd=disabled"
> +                           "-Delogind=disabled"
> +                           "-Dsystem-lua=true")))
> +    (inputs (list dbus glib lua pipewire))))
> +
>  (define-public ell
>    (package
>      (name "ell")
> --
> 2.41.0


I have modified the package definition to the following:
--8<---------------cut here---------------start------------->8---
(define-public wireplumber-minimal
  (let ((base wireplumber))
    (package
      (inherit base)
      (name "wireplumber-minimal")
      (arguments
       (substitute-keyword-arguments (package-arguments base)
         ((#:configure-flags flags ''())
          #~(cons "-Delogind=disabled" #$flags))))
      (inputs
       (modify-inputs (package-inputs base)
         (delete "elogind"))))))
--8<---------------cut here---------------end--------------->8---

, adjusted the commit message and applied the patch as
c3b99101982be292138f067db2cd429eeeda97fb.  Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3ca756dead..999b9b4363 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9451,6 +9451,16 @@  (define-public wireplumber
 tools for managing PipeWire.")
     (license license:expat)))
 
+(define-public wireplumber-minimal
+  (package
+    (inherit wireplumber)
+    (name "wireplumber-minimal")
+    (arguments
+     `(#:configure-flags '("-Dsystemd=disabled"
+                           "-Delogind=disabled"
+                           "-Dsystem-lua=true")))
+    (inputs (list dbus glib lua pipewire))))
+
 (define-public ell
   (package
     (name "ell")