diff mbox series

[bug#62733] gnu: Add r-littler

Message ID 9aa99d67ff185fdd557401c8cf6f3c90638a37c3.1681010036.git.kyle@posteo.net
State New
Headers show
Series [bug#62733] gnu: Add r-littler | expand

Commit Message

kyle April 9, 2023, 3:13 a.m. UTC
From: Kyle Andrews <kyle@posteo.net>

---
 gnu/packages/statistics.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 628057a189..e61d06721e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1010,6 +1010,42 @@  (define-public r-labeling
 algorithms.")
     (license license:expat)))
 
+(define-public r-littler
+  (package
+    (name "r-littler")
+    (version "0.3.18")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "littler" version))
+              (sha256
+               (base32
+                "1lp6a62g3yhzr4pv9kynibv7k9pd546w6hifs1aficyxbyg4dgqq"))))
+    (properties `((upstream-name . "littler")))
+    (build-system r-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+	  (add-after 'install 'add-to-path
+	    (lambda _
+              (mkdir (string-append #$output "/bin"))
+              (copy-file "inst/bin/r"
+                         (string-append #$output "/bin/r")))))))
+    (inputs (list icu4c))
+    (native-inputs
+     (list r-simplermarkdown automake autoconf zlib))
+    (home-page "https://github.com/eddelbuettel/littler")
+    (synopsis "R at the Command-Line via 'r'")
+    (description
+     "This package provides a scripting and command-line front-end is provided by r
+(aka littler') as a lightweight binary wrapper around the GNU R language and
+environment for statistical computing and graphics.  While R can be used in
+batch mode, the r binary adds full support for both shebang'-style scripting
+(i.e.  using a hash-mark-exclamation-path expression as the first line in
+scripts) as well as command-line use in standard Unix pipelines.  In other
+words, r provides the R language without the environment.")
+    (license license:gpl2+)))
+
 (define-public r-magrittr
   (package
     (name "r-magrittr")