diff mbox series

[bug#69276,1/2] gnu: libtorrent-rasterbar: Update to 2.0.10.

Message ID 9a9ec5ec-5b51-cad9-b01e-76d495752240@disroot.org
State New
Headers show
Series [bug#69276,1/2] gnu: libtorrent-rasterbar: Update to 2.0.10. | expand

Commit Message

Adam Faiz Aug. 6, 2024, 1:07 p.m. UTC
From 4af05095ca922bb6d0335a6e946a404d4764ac1f Mon Sep 17 00:00:00 2001
Message-ID: <4af05095ca922bb6d0335a6e946a404d4764ac1f.1722949379.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1722949379.git.adam.faiz@disroot.org>
References: <cover.1722949379.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Tue, 6 Aug 2024 19:57:47 +0800
Subject: [PATCH 1/2] gnu: libtorrent-rasterbar: Update to 2.0.10.

* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 2.0.10.
[source]<snippet>: Remove test/test_copy_file.cpp patch since it's resolved.
[native-inputs]: Remove no longer needed file (v2_empty_file.torrent).
[arguments]<#:phases>: And remove a phase copying it into the correct place.
---
 gnu/packages/bittorrent.scm | 28 +++-------------------------
 1 file changed, 3 insertions(+), 25 deletions(-)

Comments

Z572 Oct. 6, 2024, 9:12 a.m. UTC | #1
Adam Faiz via Guix-patches via <guix-patches@gnu.org> writes:

> From 4af05095ca922bb6d0335a6e946a404d4764ac1f Mon Sep 17 00:00:00 2001
> Message-ID: <4af05095ca922bb6d0335a6e946a404d4764ac1f.1722949379.git.adam.faiz@disroot.org>
> In-Reply-To: <cover.1722949379.git.adam.faiz@disroot.org>
> References: <cover.1722949379.git.adam.faiz@disroot.org>
> From: AwesomeAdam54321 <adam.faiz@disroot.org>
> Date: Tue, 6 Aug 2024 19:57:47 +0800
> Subject: [PATCH 1/2] gnu: libtorrent-rasterbar: Update to 2.0.10.
>
> * gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 2.0.10.
> [source]<snippet>: Remove test/test_copy_file.cpp patch since it's resolved.
> [native-inputs]: Remove no longer needed file (v2_empty_file.torrent).
> [arguments]<#:phases>: And remove a phase copying it into the correct place.
> ---
>  gnu/packages/bittorrent.scm | 28 +++-------------------------
>  1 file changed, 3 insertions(+), 25 deletions(-)
>
> diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
> index 5c2fa9c688..abc598f7fa 100644
> --- a/gnu/packages/bittorrent.scm
> +++ b/gnu/packages/bittorrent.scm
> @@ -418,16 +418,10 @@ (define-public mktorrent
>      (license (list l:public-domain      ; sha1.*, used to build without OpenSSL
>                     l:gpl2+))))          ; with permission to link with OpenSSL
>  
> -(define %v2_empty_file.torrent
> -  (origin (method url-fetch)
> -          (uri "https://github.com/arvidn/libtorrent/raw/v2.0.9/test/test_torrents/v2_empty_file.torrent")
> -          (sha256
> -           (base32 "1hydgf0m9193hy9010wl0wrbz4k4cgrqg70jakx68pgi79jcqnrn"))))
> -
>  (define-public libtorrent-rasterbar
>    (package
>      (name "libtorrent-rasterbar")
> -    (version "2.0.9")
> +    (version "2.0.10")
>      (source
>       (origin
>         (method url-fetch)
> @@ -436,14 +430,7 @@ (define-public libtorrent-rasterbar
>                         "releases/download/v" version "/"
>                         "libtorrent-rasterbar-" version ".tar.gz"))
>         (sha256
> -        (base32 "13kry578ifzz4m2f291bbd7v5v9zsi8y3mf38146cnqw0sv95kch"))
> -       ;; https://github.com/arvidn/libtorrent/issues/7566
> -       ;; Remove when resolved.  I would hope this to be fixed in 2.0.10.
> -       (modules '((guix build utils)))
> -       (snippet
> -        #~(substitute* "test/test_copy_file.cpp"
> -            (("EXT4_SUPER_MAGIC, EXT3_SUPER_MAGIC, XFS_SUPER_MAGIC" all)
> -             (string-append all ", TMPFS_MAGIC\n"))))))
> +        (base32 "0pc8rbcp7njbx8m02z47pcbbwcp5cjggbgq4sfjc19dc3n65p4zw"))))
>      (build-system cmake-build-system)
>      (arguments
>       `(#:configure-flags '("-Dpython-bindings=ON"
> @@ -452,14 +439,6 @@ (define-public libtorrent-rasterbar
>         #:parallel-tests? #f
>         #:phases
>         (modify-phases %standard-phases
> -         ;; https://github.com/arvidn/libtorrent/issues/7567
> -         ;; Remove when resolved.  I would hope this to be fixed in 2.0.10.
> -         ;; Do not forget to remove the %v2_empty_file.torrent variable.
> -         (add-before 'configure 'copy-v2_empty_file.torrent
> -           (lambda* (#:key native-inputs inputs #:allow-other-keys)
> -             (copy-file (assoc-ref (or native-inputs inputs)
> -                                   "%v2_empty_file.torrent")
> -                        "test/test_torrents/v2_empty_file.torrent")))
>           (replace 'check
>             (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
>               (let* ((disabled-tests
> @@ -502,8 +481,7 @@ (define-public libtorrent-rasterbar
>      (inputs (list boost openssl))
>      (native-inputs `(("libfaketime" ,libfaketime)
>                       ("python-wrapper" ,python-wrapper)
> -                     ("pkg-config" ,pkg-config)
> -                     ("%v2_empty_file.torrent" ,%v2_empty_file.torrent)))
> +                     ("pkg-config" ,pkg-config)))
>      (home-page "https://www.libtorrent.org/")
>      (synopsis "Feature-complete BitTorrent implementation")
>      (description

adjust message, not use #; , push and close.
diff mbox series

Patch

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 5c2fa9c688..abc598f7fa 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -418,16 +418,10 @@  (define-public mktorrent
     (license (list l:public-domain      ; sha1.*, used to build without OpenSSL
                    l:gpl2+))))          ; with permission to link with OpenSSL
 
-(define %v2_empty_file.torrent
-  (origin (method url-fetch)
-          (uri "https://github.com/arvidn/libtorrent/raw/v2.0.9/test/test_torrents/v2_empty_file.torrent")
-          (sha256
-           (base32 "1hydgf0m9193hy9010wl0wrbz4k4cgrqg70jakx68pgi79jcqnrn"))))
-
 (define-public libtorrent-rasterbar
   (package
     (name "libtorrent-rasterbar")
-    (version "2.0.9")
+    (version "2.0.10")
     (source
      (origin
        (method url-fetch)
@@ -436,14 +430,7 @@  (define-public libtorrent-rasterbar
                        "releases/download/v" version "/"
                        "libtorrent-rasterbar-" version ".tar.gz"))
        (sha256
-        (base32 "13kry578ifzz4m2f291bbd7v5v9zsi8y3mf38146cnqw0sv95kch"))
-       ;; https://github.com/arvidn/libtorrent/issues/7566
-       ;; Remove when resolved.  I would hope this to be fixed in 2.0.10.
-       (modules '((guix build utils)))
-       (snippet
-        #~(substitute* "test/test_copy_file.cpp"
-            (("EXT4_SUPER_MAGIC, EXT3_SUPER_MAGIC, XFS_SUPER_MAGIC" all)
-             (string-append all ", TMPFS_MAGIC\n"))))))
+        (base32 "0pc8rbcp7njbx8m02z47pcbbwcp5cjggbgq4sfjc19dc3n65p4zw"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags '("-Dpython-bindings=ON"
@@ -452,14 +439,6 @@  (define-public libtorrent-rasterbar
        #:parallel-tests? #f
        #:phases
        (modify-phases %standard-phases
-         ;; https://github.com/arvidn/libtorrent/issues/7567
-         ;; Remove when resolved.  I would hope this to be fixed in 2.0.10.
-         ;; Do not forget to remove the %v2_empty_file.torrent variable.
-         (add-before 'configure 'copy-v2_empty_file.torrent
-           (lambda* (#:key native-inputs inputs #:allow-other-keys)
-             (copy-file (assoc-ref (or native-inputs inputs)
-                                   "%v2_empty_file.torrent")
-                        "test/test_torrents/v2_empty_file.torrent")))
          (replace 'check
            (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
              (let* ((disabled-tests
@@ -502,8 +481,7 @@  (define-public libtorrent-rasterbar
     (inputs (list boost openssl))
     (native-inputs `(("libfaketime" ,libfaketime)
                      ("python-wrapper" ,python-wrapper)
-                     ("pkg-config" ,pkg-config)
-                     ("%v2_empty_file.torrent" ,%v2_empty_file.torrent)))
+                     ("pkg-config" ,pkg-config)))
     (home-page "https://www.libtorrent.org/")
     (synopsis "Feature-complete BitTorrent implementation")
     (description