diff mbox series

[bug#70234,3/4] gnu: Add specification-multibase.

Message ID 9a88ef1dad94a62d8dc1397bfc063dc9263ad267.1712391354.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-multiformats-go-multibase. | expand

Commit Message

Artyom V. Poptsov April 6, 2024, 8:40 a.m. UTC
* gnu/packages/specifications.scm: New module.
  (specification-multibase): New variable.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add "gnu/packages/specifications.scm".

Change-Id: I5994e8f8927d5365cc201da30bd49abf03d17574
---
 gnu/local.mk                    |  3 +-
 gnu/packages/specifications.scm | 53 +++++++++++++++++++++++++++++++++
 2 files changed, 55 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/specifications.scm
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index a281a79610..37cb54a4dd 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -49,7 +49,7 @@ 
 # Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 # Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
 # Copyright © 2022 Remco van 't Veer <remco@remworks.net>
-# Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+# Copyright © 2022, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 # Copyright © 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
 # Copyright © 2022 muradm <mail@muradm.net>
 # Copyright © 2022 Hilton Chain <hako@ultrarare.space>
@@ -609,6 +609,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/sml.scm				\
   %D%/packages/solidity.scm			\
   %D%/packages/sourcehut.scm			\
+  %D%/packages/specifications.scm		\
   %D%/packages/speech.scm			\
   %D%/packages/sphinx.scm			\
   %D%/packages/spice.scm			\
diff --git a/gnu/packages/specifications.scm b/gnu/packages/specifications.scm
new file mode 100644
index 0000000000..ce57a68bdb
--- /dev/null
+++ b/gnu/packages/specifications.scm
@@ -0,0 +1,53 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages specifications)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix gexp)
+  #:use-module (guix utils)
+  #:use-module (guix download)
+  #:use-module (guix git-download)
+  #:use-module (guix packages)
+  #:use-module (guix build-system copy))
+
+(define-public specification-multibase
+  (let ((commit "4c8344e37852773de155f587dcf5897771b3fc19")
+        (revision "1"))
+    (package
+      (name "specification-multibase")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/multiformats/multibase")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0lz4kdysa6nx7wf1i59647w7dgm344xpvfnsac3pfk2qdky2kq8b"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan
+         '(("." "share/multibase/"))))
+      (home-page "https://github.com/multiformats/multibase")
+      (synopsis "Self identifying base encodings")
+      (description
+       "Multibase is a protocol for disambiguating the encoding of
+base-encoded (e.g., @code{base32}, @code{base36}, @code{base64}, @code{base58}, etc.)
+binary appearing in text.")
+      (license (list license:expat license:cc-by-sa3.0)))))