diff mbox series

[bug#38953] v2

Message ID 9a80c128b028e7610f9dd6af4e4a0e2007053a9d.camel@disroot.org
State Accepted
Headers show
Series [bug#38953] v2 | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 7, 2020, 5:59 a.m. UTC
v2
diff mbox series

Patch

From 4187d1411efd96de2791643d667b1158c2caeba9 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Tue, 7 Jan 2020 00:54:29 -0500
Subject: [PATCH] gnu: Add gnome-photos.

* gnu/packages/gnome-xyz.scm (gnome-photos): New variable.
---
 gnu/packages/gnome-xyz.scm | 71 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 71 insertions(+)

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0fc721b7d3..e3f67a38d8 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright        2019 Raghav Gururajan <raghavgururajan@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,18 +22,88 @@ 
 (define-module (gnu packages gnome-xyz)
   #:use-module (guix build-system trivial)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system meson)
+  #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix packages)
+  #:use-module (guix utils)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gettext)
+  #:use-module (gnu packages gimp)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages image)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages ruby)
+  #:use-module (gnu packages version-control)
   #:use-module (gnu packages xml))
 
+(define-public gnome-photos
+  (package
+   (name "gnome-photos")
+   (version "3.34.0")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/" name "/"
+                                (version-major+minor version) "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "12j455id5g616cn0nnj73v83aqgpavrsqszw1r5yhbpyc76lg03m"))))
+   (build-system meson-build-system)
+   (arguments
+    `(#:glib-or-gtk? #t
+      ;; dogtail test-suite not available.
+      #:configure-flags `("-Ddogtail=false")
+      #:configure-flags
+       (list "-Dsystemduserunitdir=no"
+             "-Dtmpfilesdir=no"
+             ;; Required for RUNPATH validation.
+             (string-append "-Dc_link_args=-Wl,-rpath="
+                            (assoc-ref %outputs "out") "/lib/gnome-photos"))))
+   (native-inputs
+    `(("glib:bin" ,glib "bin")
+      ("itstool" ,itstool)
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("adwaita-icon-theme" ,adwaita-icon-theme)
+      ("babl" ,babl)
+      ("cairo" ,cairo)
+      ("dbus" ,dbus)
+      ("desktop-file-utils" ,desktop-file-utils)
+      ("gdk-pixbuf" ,gdk-pixbuf+svg)
+      ("gegl" ,gegl)
+      ("gettext" ,gettext-minimal)
+      ("geocode-glib" ,geocode-glib)
+      ("gexiv2" ,gexiv2)
+      ("git" ,git-minimal)
+      ("gnome-online-accounts" ,gnome-online-accounts)
+      ("gnome-online-miners" ,gnome-online-miners)
+      ("gobject-introspection" ,gobject-introspection)
+      ("grilo" ,grilo)
+      ("grilo-plugins" ,grilo-plugins)
+      ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+      ("gtk+:bin" ,gtk+ "bin")
+      ("libdazzle" ,libdazzle)
+      ("libgdata" ,libgdata)
+      ("libgfbgraph" ,gfbgraph)
+      ("libjpeg" ,libjpeg)
+      ("libpng" ,libpng)
+      ("librest" ,rest)
+      ("pygobject" ,python-pygobject)
+      ("tracker" ,tracker)
+      ("tracker-miners" ,tracker-miners)))
+   (synopsis "Access, organize and share your photos on GNOME desktop")
+   (description "GNOME Photos is a simple and elegant replacement for
+using a file manager to deal with photos. Enhance, crop and edit in a snap.
+Seamless cloud integration is offered through GNOME Online Accounts.")
+   (home-page "https://wiki.gnome.org/Apps/Photos")
+   (license license:gpl2)))
+
 (define-public matcha-theme
   (package
     (name "matcha-theme")
-- 
2.24.1