diff mbox series

[bug#70769] gnu: Add python-clintest.

Message ID 9a730ca2b2a4f5b64083da4f6985745ca29264ca.1714808929.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#70769] gnu: Add python-clintest. | expand

Commit Message

Liliana Marie Prikler May 4, 2024, 6:31 a.m. UTC
* gnu/packages/potassco.scm (python-clintest): New variable.
---
 gnu/packages/potassco.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 5c13ab50b9c7d44238c64e5337027f04ae1d9223

Comments

Nicolas Graves May 13, 2024, 7:10 a.m. UTC | #1
On 2024-05-04 08:31, Liliana Marie Prikler wrote:

> * gnu/packages/potassco.scm (python-clintest): New variable.
> ---
>  gnu/packages/potassco.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
> index 43d9ea6647..6a124c5bba 100644
> --- a/gnu/packages/potassco.scm
> +++ b/gnu/packages/potassco.scm
> @@ -612,3 +612,27 @@ (define-public python-clinguin
>     (description "Clinguin is a graphical user interface toolkit for clingo,
>  which allows user interfaces to be specified entirely as a logic program.")
>     (license license:expat)))
> +
> +(define-public python-clintest
> +  (package
> +    (name "python-clintest")
> +    (version "0.2.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/potassco/clintest")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "0xzbby9ram55h87ykm652kgm45b8rlhbjc8gjkz308h1jnjllmmy"))))
> +    (build-system pyproject-build-system)
> +    (inputs (list python-clingo))

You can add (native-inputs (list python-pytest)) to enable tests
properly. There are quite some tests that are failing for some reason
(10/31), it's unclear why at first glance.

We probably should add this native-input and ignore failing tests.

Otherwise LGTM, builds properly.

> +    (home-page "https://potassco.org/clintest/")
> +    (synopsis "Test framework for clingo programs")
> +    (description "Clintest is a framework for unit testing clingo programs.
> +It provides various components to assemble the most commonly used tests quickly,
> +but also works fine along custom-built test.  Clintest monitors the test
> +outcome while solving to abort the search for solutions once the outcome is
> +certain.")
> +    (license license:expat)))
>
> base-commit: 5c13ab50b9c7d44238c64e5337027f04ae1d9223
Liliana Marie Prikler May 14, 2024, 5:49 a.m. UTC | #2
Am Montag, dem 13.05.2024 um 09:10 +0200 schrieb Nicolas Graves:
> You can add (native-inputs (list python-pytest)) to enable tests
> properly. There are quite some tests that are failing for some reason
> (10/31), it's unclear why at first glance.
> 
> We probably should add this native-input and ignore failing tests.
> 
> Otherwise LGTM, builds properly.
It appears to be a known issue from python-clingo already – we'll still
have to figure out the root cause for that as well.  Added a fixme and
pushed.

Thanks
diff mbox series

Patch

diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 43d9ea6647..6a124c5bba 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -612,3 +612,27 @@  (define-public python-clinguin
    (description "Clinguin is a graphical user interface toolkit for clingo,
 which allows user interfaces to be specified entirely as a logic program.")
    (license license:expat)))
+
+(define-public python-clintest
+  (package
+    (name "python-clintest")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/potassco/clintest")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0xzbby9ram55h87ykm652kgm45b8rlhbjc8gjkz308h1jnjllmmy"))))
+    (build-system pyproject-build-system)
+    (inputs (list python-clingo))
+    (home-page "https://potassco.org/clintest/")
+    (synopsis "Test framework for clingo programs")
+    (description "Clintest is a framework for unit testing clingo programs.
+It provides various components to assemble the most commonly used tests quickly,
+but also works fine along custom-built test.  Clintest monitors the test
+outcome while solving to abort the search for solutions once the outcome is
+certain.")
+    (license license:expat)))