diff mbox series

[bug#56658] gnu: Add lkrg.

Message ID 9UfWRYkSni-i6ElqO7Hhd4IuRBKyasRwZ_r05cFBp97jn4Eh0JyHqwJTaD8DLp8cg49Iu5Tson0TkWHMbinpXA1neJ69F3f6iy4YJ-SGp7o=@protonmail.com
State Accepted
Headers show
Series [bug#56658] gnu: Add lkrg. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina July 20, 2022, 8:59 a.m. UTC
Hi,

this patch adds kernel module to improve runtime security of the system.

----
Petr

Comments

Ludovic Courtès Aug. 4, 2022, 10:06 p.m. UTC | #1
Hi,

phodina <phodina@protonmail.com> skribis:

> From 985199faeb4164df909d8c6b48ba941c62312266 Mon Sep 17 00:00:00 2001
> From: Petr Hodina <phodina@protonmail.com>
> Date: Wed, 20 Jul 2022 10:28:30 +0200
> Subject: [PATCH] gnu: Add lkrg.
>
> * gnu/packages/linux.scm (lkrg): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 985199faeb4164df909d8c6b48ba941c62312266 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Wed, 20 Jul 2022 10:28:30 +0200
Subject: [PATCH] gnu: Add lkrg.

* gnu/packages/linux.scm (lkrg): New variable.

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 48beae0e69..a46a74401c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -60,7 +60,7 @@ 
 ;;; Copyright © 2021 Josselin Poiret <josselin.poiret@protonmail.ch>
 ;;; Copyright © 2021 Olivier Dion <olivier.dion@polymtl.ca>
 ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
-;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
 
@@ -1342,6 +1342,37 @@  (define-public librem-ec-acpi-linux-module
 and the notification, WiFi, and Bluetooth LED.")
     (license license:gpl2)))
 
+(define-public lkrg
+  (package
+    (name "lkrg")
+    (version "0.9.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/lkrg-org/lkrg")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0yirb7n4mqv8cn0gziz1m7ymq00dhhy79j59jdgrx00b8rj57cfw"))))
+    (build-system linux-module-build-system)
+    (arguments
+     (list #:linux linux-libre
+           #:tests? #f
+           #:make-flags #~(list (string-append "CC="
+                                               #$(cc-for-target))
+                                (string-append "SYSSRC="
+                                               (assoc-ref %build-inputs
+                                                "linux-module-builder")
+                                               "/lib/modules/build"))))
+    (inputs (list bash-minimal))
+    (home-page "https://lkrg.org/")
+    (synopsis "Linux Kernel Runtime Guard")
+    (description
+     "This package performs runtime integrity checking of the Linux kernel and
+detection of security vulnerability exploits against the kernel.")
+    (license license:gpl2)))
+
 (define-public rtl8821ce-linux-module
   (let ((commit "be733dc86781c68571650b395dd0fa6b53c0a039")
         (revision "6"))
-- 
2.37.0