diff mbox series

[bug#63914] gnu: Add perl-test-inter.

Message ID 99e898584603e10d535289b5446d3bfb496a3f54.1685990633.git.hrn@posteo.net
State New
Headers show
Series [bug#63914] gnu: Add perl-test-inter. | expand

Commit Message

hrn June 5, 2023, 6:44 p.m. UTC
---
 gnu/packages/perl-check.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: a025d8fee6c8df1db750058d41f984103eb77978

Comments

宋文武 July 22, 2023, 3:20 a.m. UTC | #1
Thank you for the patch, I applied it with improved (hopefully) description:


-     "Another framework for writing test scripts.  Much of the
-syntax is loosely inspired by Test::More, and Test::Inter has most of its
-functionality, but is not a drop-in replacement")
+     "@code{Test::Inter} is another framework for writing test scripts, which
+offer the ability to access specific tests in a reasonably interactive
+fashion, primarily for debugging purposes.  Much of the syntax is loosely
diff mbox series

Patch

diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 7bf58832bc..39fdac29be 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -39,6 +39,7 @@  (define-module (gnu packages perl-check)
   #:use-module (gnu packages web)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system perl)
   #:use-module (gnu packages perl))
 
@@ -715,6 +716,28 @@  (define-public perl-test-harness
 automatically aggregated and output to STDOUT.")
     (license perl-license)))
 
+(define-public perl-test-inter
+  (package
+    (name "perl-test-inter")
+    (version "1.10")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/SBECK-github/Test-Inter")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0ii3avmd31j3kxg456jqvlj5w0hpywpj51mqm4ccnjm820yv8irb"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/pod/Test::Inter")
+    (synopsis "Framework for more readable interactive test scripts")
+    (description
+     "Another framework for writing test scripts.  Much of the
+syntax is loosely inspired by Test::More, and Test::Inter has most of its
+functionality, but is not a drop-in replacement")
+    (license perl-license)))
+
 (define-public perl-test-leaktrace
   (package
     (name "perl-test-leaktrace")