diff mbox series

[bug#47274] Linphone Packages

Message ID 9944d20f-23f1-6fcf-ac63-34f2b359e750@raghavgururajan.name
State Accepted
Headers show
Series [bug#47274] Linphone Packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan March 29, 2021, 6:47 p.m. UTC
Hi Maxim!

> Yes! Both running the binary directly from the store or in a pure
> environment, multiple times have worked after the above change.  Do you
> experience failures still?

Yes! Connection to linphone account fails due to missing 
/share/linphone/rootca.pem and loading of codecs fails due to missing 
/lib. I have fixed them in the attached patch. Could you merge it please?

Thank you!

Regards,
RG.
diff mbox series

Patch

From a974271757ea113e9b757c2f520273e774134b6a Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Mon, 29 Mar 2021 03:19:09 -0400
Subject: [PATCH] gnu: linphone-desktop: Fix functionality.

* gnu/packages/linphone.scm (linphone-desktop)[phases](post-install): Modify phase.
---
 gnu/packages/linphone.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 2107560aa0..deda49a4bc 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -839,10 +839,14 @@  and video calls or instant messaging capabilities to an application.")
                ;; Remove unnecessary Qt configuration file.
                (delete-file (string-append out "/bin/qt.conf"))
                ;; Not using the FHS exposes an issue where the client
-               ;; refers to its own "share" directory, which lacks files
+               ;; refers to its own directories, which lacks files
                ;; installed by the dependencies.
+               (symlink (string-append liblinphone "/lib")
+                        (string-append out "/lib"))
                (symlink (string-append liblinphone "/share/sounds")
                         (string-append out "/share/sounds"))
+               (symlink (string-append liblinphone "/share/linphone/rootca.pem")
+                        (string-append out "/share/linphone/rootca.pem"))
                (mkdir-p (dirname grammar-dest))
                (symlink (string-append liblinphone "/share/belr/grammars")
                         grammar-dest)))))))
-- 
2.31.1