diff mbox series

[bug#68656,core-updates,1/7] gnu: cryptsetup: Update to 2.6.1.

Message ID 9939efb9bb6e769d0a0298183128e4b6c34771d2.1705762361.git.dev@jpoiret.xyz
State New
Headers show
Series Cryptsetup woes | expand

Commit Message

Josselin Poiret Jan. 22, 2024, 1:36 p.m. UTC
From: Josselin Poiret <dev@jpoiret.xyz>

* gnu/packages/cryptsetup.scm (cryptsetup): Update to 2.6.1.  Disable external
tokens for now.

Change-Id: I5610cabfbd46d010a8241430d8d90f5920847c04
---
 gnu/packages/cryptsetup.scm | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/cryptsetup.scm b/gnu/packages/cryptsetup.scm
index 3bdc68ae5a..3cb669206a 100644
--- a/gnu/packages/cryptsetup.scm
+++ b/gnu/packages/cryptsetup.scm
@@ -30,12 +30,13 @@  (define-module (gnu packages cryptsetup)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages ruby)
   #:use-module (gnu packages web))
 
 (define-public cryptsetup
   (package
    (name "cryptsetup")
-   (version "2.3.7")
+   (version "2.6.1")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://kernel.org/linux/utils/cryptsetup/v"
@@ -43,7 +44,7 @@  (define-public cryptsetup
                                 "/cryptsetup-" version ".tar.xz"))
             (sha256
              (base32
-              "1a97rvi6arsj8dikh1qsvixx9rizm89k155q2ypifqlqllr530v1"))))
+              "14s6vbb9llpgnhmv0badxxzhi73jp4vyvp8swk4bjah7l5jys3a1"))))
    (build-system gnu-build-system)
    (arguments
     `(#:configure-flags
@@ -54,12 +55,16 @@  (define-public cryptsetup
        "--with-crypto_backend=gcrypt"
        ;; GRUB 2.06 supports LUKS2, but does it reliably support all set-ups…?
        "--with-default-luks-format=LUKS1"
+       ;; External tokens would need an env variable to work on Guix, and we
+       ;; don't have users for it yet.
+       "--disable-external-tokens"
+       "--disable-ssh-token"
        ;; libgcrypt is not found otherwise when cross-compiling.
        ;; <https://issues.guix.gnu.org/63864>
        (string-append "--with-libgcrypt-prefix="
                       (assoc-ref %build-inputs "libgcrypt")))))
    (native-inputs
-    (list pkg-config))
+    (list pkg-config ruby-asciidoctor))
    (inputs
     (list argon2
           json-c