diff mbox series

[bug#38849] Fix IBus-Rime

Message ID 9931577874508@vla1-74bb1214b343.qloud-c.yandex.net
State Accepted
Headers show
Series [bug#38849] Fix IBus-Rime | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ivan Kozlov Jan. 1, 2020, 10:28 a.m. UTC
IBus uses the component file rime.xml to start the Rime engine. It must be patched with appropriate paths.

---
 gnu/packages/ibus.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Ludovic Courtès Jan. 6, 2020, 2:26 p.m. UTC | #1
Hello,

kanichos@yandex.ru skribis:

> IBus uses the component file rime.xml to start the Rime engine. It must be patched with appropriate paths.
>
> ---
>  gnu/packages/ibus.scm | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
> index 42a8d5db32..7daefde021 100644
> --- a/gnu/packages/ibus.scm
> +++ b/gnu/packages/ibus.scm
> @@ -668,6 +668,10 @@ Method Engine.")
>                                 (assoc-ref inputs "rime-data")
>                                 "/share/rime-data\"\n")))
>               #t))
> +         (add-after 'unpack 'fix-paths
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             (substitute* "rime.xml"
> +               (("/usr") (assoc-ref outputs "out"))) #t))

I made the following changes:

  1. Move the explanation as a comment in the code.

  2. Write “file name” instead of “path”, for consistency.

  3. Write a commit log that follows the project’s conventions.

Committed now, thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 42a8d5db32..7daefde021 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -668,6 +668,10 @@  Method Engine.")
                                (assoc-ref inputs "rime-data")
                                "/share/rime-data\"\n")))
              #t))
+         (add-after 'unpack 'fix-paths
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "rime.xml"
+               (("/usr") (assoc-ref outputs "out"))) #t))
          (delete 'configure))))
     (inputs
      `(("gdk-pixbuf" ,gdk-pixbuf)