diff mbox series

[bug#66548] (no subject)

Message ID 9909834b-348c-462c-b061-09b7e69ff251@runbox.com
State New
Headers show
Series [bug#66548] (no subject) | expand

Commit Message

Jaeme Sifat Oct. 15, 2023, 3:03 a.m. UTC
I revised my patch to not include older versions of rust-alsa as they 
are not needed.


From bb9a39beb92190d315284196ee63274e359fa657 Mon Sep 17 00:00:00 2001
From: jaeme <jaeme@runbox.com>
Date: Sat, 14 Oct 2023 22:54:54 -0400
Subject: [PATCH] gnu: Add rust-alsa

* gnu/packages/crates-io.scm (rust-alsa-0.8): New variable.
* gnu/packages/crates-io.scm (rust-alsa-sys-0.3): New variable.
* gnu/packages/crates-io.scm (rust-bitflags-2): Update to 2.4.0.
* gnu/packages/crates-io.scm: Update copyright header.

Signed-off-by: jaeme <jaeme@runbox.com>
---
  gnu/packages/crates-io.scm | 89 +++++++++++++++++++++++++++++---------
  1 file changed, 69 insertions(+), 20 deletions(-)

    (package
      (name "rust-always-assert")
@@ -7736,38 +7788,35 @@ (define-public rust-bitfield-0.13
  (define-public rust-bitflags-2
    (package
      (name "rust-bitflags")
-    (version "2.3.3")
+    (version "2.4.0")
      (source
       (origin
         (method url-fetch)
         (uri (crate-uri "bitflags" version))
         (file-name (string-append name "-" version ".tar.gz"))
         (sha256
-        (base32 "0hifjw3191g3w5cwqqvbx8knrr3zchdwfc3rs6mn11p5si9yf2v3"))))
+        (base32 "0dc6xa7flfl59makmhixjcrslwlvdxxwrgxbr8p7bkvz53k2ls5l"))))
      (build-system cargo-build-system)
      (arguments
-     `(#:tests? #f      ; Not all files included.
-       #:cargo-inputs
-       (("rust-arbitrary" ,rust-arbitrary-1)
-        ("rust-bytemuck" ,rust-bytemuck-1)
-        ("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
-        ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
-        ("rust-serde" ,rust-serde-1))
-       #:cargo-development-inputs
-       (("rust-arbitrary" ,rust-arbitrary-1)
-        ("rust-bytemuck" ,rust-bytemuck-1)
-        ("rust-rustversion" ,rust-rustversion-1)
-        ("rust-serde-derive" ,rust-serde-derive-1)
-        ("rust-serde-json" ,rust-serde-json-1)
-        ("rust-serde-test" ,rust-serde-test-1)
-        ("rust-trybuild" ,rust-trybuild-1)
-        ("rust-zerocopy" ,rust-zerocopy-0.6))))
+     `(#:tests? #f ;Not all files included.
+       #:cargo-inputs (("rust-arbitrary" ,rust-arbitrary-1)
+                       ("rust-bytemuck" ,rust-bytemuck-1)
+                       ("rust-compiler-builtins" 
,rust-compiler-builtins-0.1)
+                       ("rust-rustc-std-workspace-core" 
,rust-rustc-std-workspace-core-1)
+                       ("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs (("rust-arbitrary" ,rust-arbitrary-1)
+                                   ("rust-bytemuck" ,rust-bytemuck-1)
+                                   ("rust-rustversion" ,rust-rustversion-1)
+                                   ("rust-serde-derive" 
,rust-serde-derive-1)
+                                   ("rust-serde-json" ,rust-serde-json-1)
+                                   ("rust-serde-test" ,rust-serde-test-1)
+                                   ("rust-trybuild" ,rust-trybuild-1)
+                                   ("rust-zerocopy" ,rust-zerocopy-0.6))))
      (home-page "https://github.com/bitflags/bitflags")
      (synopsis "Macro to generate structures which behave like bitflags")
      (description "This package provides a macro to generate structures 
which
  behave like a set of bitflags.")
-    (license (list license:asl2.0
-                   license:expat))))
+    (license (list license:asl2.0 license:expat))))

  (define-public rust-bitflags-1
    (package

Comments

Christopher Baines Oct. 18, 2023, 8:44 a.m. UTC | #1
Jaeme Sifat via Guix-patches via <guix-patches@gnu.org> writes:

> I revised my patch to not include older versions of rust-alsa as they
> are not needed.
>
>
> From bb9a39beb92190d315284196ee63274e359fa657 Mon Sep 17 00:00:00 2001
> From: jaeme <jaeme@runbox.com>
> Date: Sat, 14 Oct 2023 22:54:54 -0400
> Subject: [PATCH] gnu: Add rust-alsa
>
> * gnu/packages/crates-io.scm (rust-alsa-0.8): New variable.
> * gnu/packages/crates-io.scm (rust-alsa-sys-0.3): New variable.
> * gnu/packages/crates-io.scm (rust-bitflags-2): Update to 2.4.0.
> * gnu/packages/crates-io.scm: Update copyright header.

Hi Jaeme,

Would you be able to split this up in to three commits/patches, with one
package added/updated per commit?

I did try to apply the patch, but wasn't able to. I think Git took issue
with the format of the email (and it seemed to have lots of non breaking
spaces in it as well). Could you use git send-email to send the patches,
or maybe generate patch files and send them one by one as attachments if
git send-email isn't possible for you?

Thanks,

Chris
Jaeme Sifat Oct. 23, 2023, 5:38 a.m. UTC | #2
I redid my patches again, I split it up into 2 patches for rust-alsa and 
rust-alsa-sys since bitflags was updated on master.

On 10/18/23 04:44, Christopher Baines wrote:
> Jaeme Sifat via Guix-patches via <guix-patches@gnu.org> writes:
>
>> I revised my patch to not include older versions of rust-alsa as they
>> are not needed.
>>
>>
>>  From bb9a39beb92190d315284196ee63274e359fa657 Mon Sep 17 00:00:00 2001
>> From: jaeme <jaeme@runbox.com>
>> Date: Sat, 14 Oct 2023 22:54:54 -0400
>> Subject: [PATCH] gnu: Add rust-alsa
>>
>> * gnu/packages/crates-io.scm (rust-alsa-0.8): New variable.
>> * gnu/packages/crates-io.scm (rust-alsa-sys-0.3): New variable.
>> * gnu/packages/crates-io.scm (rust-bitflags-2): Update to 2.4.0.
>> * gnu/packages/crates-io.scm: Update copyright header.
> Hi Jaeme,
>
> Would you be able to split this up in to three commits/patches, with one
> package added/updated per commit?
>
> I did try to apply the patch, but wasn't able to. I think Git took issue
> with the format of the email (and it seemed to have lots of non breaking
> spaces in it as well). Could you use git send-email to send the patches,
> or maybe generate patch files and send them one by one as attachments if
> git send-email isn't possible for you?
>
> Thanks,
>
> Chris
Jaeme Sifat Oct. 23, 2023, 2:10 p.m. UTC | #3
This issue was open as a mistake and was related to 
https://issues.guix.gnu.org/66548

This can be removed.
vasilii.smirnov--- via Guix-patches" via Oct. 25, 2023, 12:47 a.m. UTC | #4
close 66695
vasilii.smirnov--- via Guix-patches" via Oct. 25, 2023, 1:03 a.m. UTC | #5
So I apparently cannot close this bug, but you can jaeme:

https://debbugs.gnu.org/server-control.html

I personally use emacs-debbugs to close bug reports. It is fairly
easy wants you get it set up.
Jaeme Sifat Oct. 25, 2023, 1:42 a.m. UTC | #6
close 66695
Jaeme Sifat Oct. 25, 2023, 1:52 a.m. UTC | #7
close 66695
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 80fb92ec82..bca76f66ec 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32,6 +32,7 @@ 
  ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
  ;;; Copyright © 2022 Paul Alesius <paul@unnservice.com>
  ;;; Copyright © 2023 Arnav Andrew Jose <arnav.jose@gmail.com>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -2917,6 +2918,57 @@  (define-public rust-allocator-api2-0.2
      (description "Mirror of Rust's allocator API.")
      (license (list license:expat license:asl2.0))))

+(define-public rust-alsa-0.8
+  (package
+    (name "rust-alsa")
+    (version "0.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "alsa" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "02k93vj8h789qx6as8yzi7r2wycqgmcsmk6m1pbb99dkwkhhjwww"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f ;integration tests fail on ALSA lib
+       #:cargo-inputs (("rust-alsa-sys" ,rust-alsa-sys-0.3)
+                       ("rust-bitflags" ,rust-bitflags-2)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-nix" ,rust-nix-0.26))))
+    (inputs (list alsa-lib))
+    (native-inputs (list pkg-config))
+    (home-page "https://github.com/diwic/alsa-rs")
+    (synopsis "Thin but safe wrappers for ALSA (Linux sound API) in Rust")
+    (description
+     "This package provides thin but safe wrappers for ALSA in Rust 
which is
+the most common API for accessing audio devices.")
+    (license (list license:asl2.0 license:expat))))
+
+(define-public rust-alsa-sys-0.3
+  (package
+    (name "rust-alsa-sys")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "alsa-sys" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "09qmmnpmlcj23zcgx2xsi4phcgm5i02g9xaf801y7i067mkfx3yv"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f ;doc tests fail due to scoping issues
+       #:cargo-inputs (("rust-libc" ,rust-libc-0.2)
+                       ("rust-pkg-config" ,rust-pkg-config-0.3))))
+    (inputs (list alsa-lib))
+    (native-inputs (list pkg-config))
+    (home-page "https://github.com/diwic/alsa-sys")
+    (synopsis
+     "Rust FFI bindings for the ALSA project (Advanced Linux Sound 
Architecture)")
+    (description "This crate provides raw Rust FFI bindings for ALSA.")
+    (license license:expat)))
+
  (define-public rust-always-assert-0.1