diff mbox series

[bug#38095] gnu: Add matcha-theme.

Message ID 9909000076a769a986d20f8712273d99@posteo.net
State Accepted
Headers show
Series [bug#38095] gnu: Add matcha-theme. | expand

Commit Message

Alexandros Theodotou Nov. 8, 2019, 11:47 p.m. UTC
Fixed formatting issues

 From 774b2af8acf06474bde79c78a0a356c24cc8480b Mon Sep 17 00:00:00 2001
 From: Alexandros Theodotou <alex@zrythm.org>
Date: Thu, 7 Nov 2019 05:37:42 +0000
Subject: [PATCH] gnu: Add matcha-theme.

* gnu/packages/gnome.scm (matcha-theme): New variable.
---
  gnu/packages/gnome.scm | 47 ++++++++++++++++++++++++++++++++++++++++++
  1 file changed, 47 insertions(+)

    (package
      (name "arc-theme")
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cd881b5b87..66a5745824 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -42,6 +42,7 @@ 
  ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
  ;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
  ;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -7105,6 +7106,52 @@  dark elements.  It supports GNOME, Unity, Xfce, 
and Openbox.")
      (home-page "https://numixproject.github.io")
      (license license:gpl3+)))

+(define-public matcha-theme
+  (package
+    (name "matcha-theme")
+    (version "2019-11-02")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/vinceliuice/matcha")
+            (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0wci9ahap8kynq8cbyxr7aba9ndb1d4kiq42xvzr34vw1rhcahrr"))))
+    (build-system trivial-build-system)
+    (arguments
+     '(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+         (let* ((out (assoc-ref %outputs "out"))
+                (source (assoc-ref %build-inputs "source"))
+                (bash (assoc-ref %build-inputs "bash"))
+                (coreutils (assoc-ref %build-inputs  "coreutils"))
+                (themesdir (string-append out "/share/themes")))
+           (setenv "PATH"
+                   (string-append coreutils "/bin:"
+                                  (string-append bash "/bin:")))
+           (copy-recursively source (getcwd))
+           (patch-shebang "Install")
+           (mkdir-p themesdir)
+           (invoke "./Install" "-d" themesdir)
+           #t))))
+    (inputs
+     `(("gtk-engines", gtk-engines)))
+    (native-inputs
+     `(("bash", bash)
+       ("coreutils", coreutils)))
+    (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
+    (description "Matcha is a flat Design theme for GTK 3, GTK 2 and
+Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments 
like
+Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
+    (home-page "https://github.com/vinceliuice/matcha")
+    (license license:gpl3)))
+
  (define-public arc-theme