diff mbox series

[bug#38116] gnu: jalv: Fix gtkmm, add gtk+-2 and qtbase.

Message ID 98eb79dfe4efd7109d771e60f9b679d3@posteo.net
State Accepted
Headers show
Series [bug#38116] gnu: jalv: Fix gtkmm, add gtk+-2 and qtbase. | expand

Commit Message

Alexandros Theodotou Nov. 8, 2019, 9:14 a.m. UTC
The gtkmm passed to inputs was unused. Jalv does not support gtkmm 3 at 
the moment.

Also, Jalv is the main tool LV2 plugin developers use to test their 
plugins. Having more variants
(qt5, gtk2) means you have more types of hosts to test your plugins in 
so this is an
extremely useful addition.

 From 2ec5fb34c2600c893763ae95d69bf2bd77d17b61 Mon Sep 17 00:00:00 2001
 From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:05:10 +0000
Subject: [PATCH] gnu: jalv: Fix gtkmm, add gtk+-2 and qtbase.

* gnu/packages/audio.scm (jalv)[inputs]:
Add gtk+-2 and qtbase.
Change unused gtkmm to gtkmm-2.
---
  gnu/packages/audio.scm | 6 ++++--
  1 file changed, 4 insertions(+), 2 deletions(-)

       `(("pkg-config" ,pkg-config)))

Comments

Marius Bakke Nov. 10, 2019, 10:39 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> The gtkmm passed to inputs was unused. Jalv does not support gtkmm 3 at 
> the moment.
>
> Also, Jalv is the main tool LV2 plugin developers use to test their 
> plugins. Having more variants
> (qt5, gtk2) means you have more types of hosts to test your plugins in 
> so this is an
> extremely useful addition.
>
>  From 2ec5fb34c2600c893763ae95d69bf2bd77d17b61 Mon Sep 17 00:00:00 2001
>  From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:05:10 +0000
> Subject: [PATCH] gnu: jalv: Fix gtkmm, add gtk+-2 and qtbase.
>
> * gnu/packages/audio.scm (jalv)[inputs]:
> Add gtk+-2 and qtbase.
> Change unused gtkmm to gtkmm-2.

Thanks!  'guix size jalv' increases from 1482.2 MiB to 1501.2 MiB with
this patch due to the addition of gtkmm@2, which seems fine.

Applied!
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 28dbf06f3b..ca2d86d525 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1599,8 +1599,10 @@  synchronous execution of all clients, and low 
latency operation.")
       `(("lv2" ,lv2)
         ("lilv" ,lilv)
         ("suil" ,suil)
-       ("gtk" ,gtk+)
-       ("gtkmm" ,gtkmm)
+       ("gtk2" ,gtk+-2)
+       ("gtk3" ,gtk+)
+       ("gtkmm" ,gtkmm-2)
+       ("qtbase" ,qtbase)
         ("jack" ,jack-1)))
      (native-inputs