diff mbox series

[bug#57757] * gnu/packages/wm.scm: Add sbcl-stumpwm-pamixer

Message ID 989c9758e8200e80725bba437bdbc6a3e5ccf56e.1663018914.git.trev@trevdev.ca
State Accepted
Headers show
Series [bug#57757] * gnu/packages/wm.scm: Add sbcl-stumpwm-pamixer | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Trevor Richards Sept. 12, 2022, 9:41 p.m. UTC
Hello,

This patch adds sbcl-stumpwm-pamixer which provides convenient commands
for manipulating your volume levels/sinks within stumpwm.

---
 gnu/packages/wm.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

M Sept. 16, 2022, 9:07 a.m. UTC | #1
On 12-09-2022 23:41, Trevor Richards wrote:
> +      (inputs `(("stumpwm" ,stumpwm "lib")))

Try running "./pre-inst-env guix style --input-simplification=always 
sbcl-stumpwm-pamixer", it will have a proposed change.

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/Junker/stumpwm-pamixer.git")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "0djcrr16bx40l7b60d4j507vk5l42fdgmjpgrnk86z1ba8wlqim8"))))

IIUC, "guix lint" will have a lint message about that URI, asking you to 
drop the .git suffix.  '(guix)Submitting Patches' asks to run 
'./pre-inst-env guix lint sbcl-stumpwm-pamixer'.

Greetings,
Maxime
Trevor Richards Sept. 19, 2022, 2:31 p.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:

> On 12-09-2022 23:41, Trevor Richards wrote:
>> +      (inputs `(("stumpwm" ,stumpwm "lib")))
>
> Try running "./pre-inst-env guix style --input-simplification=always 
> sbcl-stumpwm-pamixer", it will have a proposed change.
>

In my case it does not. I updated the label to "stumpwm:lib" in the
hopes that I could patch it the way we like it.

>> +      (source
>> +       (origin
>> +         (method git-fetch)
>> +         (uri (git-reference
>> +               (url "https://github.com/Junker/stumpwm-pamixer.git")
>> +               (commit commit)))
>> +         (file-name (git-file-name name version))
>> +         (sha256
>> +          (base32 "0djcrr16bx40l7b60d4j507vk5l42fdgmjpgrnk86z1ba8wlqim8"))))
>
> IIUC, "guix lint" will have a lint message about that URI, asking you to 
> drop the .git suffix.  '(guix)Submitting Patches' asks to run 
> './pre-inst-env guix lint sbcl-stumpwm-pamixer'.
>

No problem, I dropped the .git
M Sept. 19, 2022, 4:17 p.m. UTC | #3
On 19-09-2022 16:31, Trev wrote:
> Maxime Devos <maximedevos@telenet.be> writes:
> 
>> On 12-09-2022 23:41, Trevor Richards wrote:
>>> +      (inputs `(("stumpwm" ,stumpwm "lib")))
>>
>> Try running "./pre-inst-env guix style --input-simplification=always
>> sbcl-stumpwm-pamixer", it will have a proposed change.
>>
> 
> In my case it does not. I updated the label to "stumpwm:lib" in the
> hopes that I could patch it the way we like it.

OK, didn't expect that.  IIUC, you can drop the input label with

(inputs (list `(,stumpwm "lib")))

Greetings,
Maxime.
Trevor Richards Sept. 19, 2022, 5:29 p.m. UTC | #4
Maxime Devos <maximedevos@telenet.be> writes:

>>> On 12-09-2022 23:41, Trevor Richards wrote:
>>>> +      (inputs `(("stumpwm" ,stumpwm "lib")))
>>>
>>> Try running "./pre-inst-env guix style --input-simplification=always
>>> sbcl-stumpwm-pamixer", it will have a proposed change.
>>>
>> 
>> In my case it does not. I updated the label to "stumpwm:lib" in the
>> hopes that I could patch it the way we like it.
>
> OK, didn't expect that.  IIUC, you can drop the input label with
>
> (inputs (list `(,stumpwm "lib")))
>

Yes, this is preferrable. I will send a third revision of the patch.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 451dfce516..3f2258db52 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1986,6 +1986,31 @@  (define-public stumpish
     (description "This package provides a StumpWM interactive shell.")
     (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
 
+(define-public sbcl-stumpwm-pamixer
+  (let ((commit "aa820533c80ea1af5a0e107cea25eaf34e69dc24")
+        (revision "1"))
+    (package
+      (name "sbcl-stumpwm-pamixer")
+      (version (git-version "0.1.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Junker/stumpwm-pamixer.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0djcrr16bx40l7b60d4j507vk5l42fdgmjpgrnk86z1ba8wlqim8"))))
+      (inputs `(("stumpwm" ,stumpwm "lib")))
+      (propagated-inputs (list pamixer))
+      (build-system asdf-build-system/sbcl)
+      (arguments '(#:asd-systems '(:pamixer)))
+      (home-page "https://github.com/Junker/stumpwm-pamixer")
+      (synopsis "StumpWM Pamixer Module")
+      (description "Minimalistic Pulseaudio volume and microphone control
+module for StumpWM.")
+      (license license:gpl3))))
+
 (define-public sbcl-stumpwm+slynk
   (deprecated-package "sbcl-stumpwm-with-slynk" stumpwm+slynk))