[bug#77398,v2] gnu: xrdp: Update to 0.10.3, xorgxrdp: Update to 0.10.4.
Commit Message
* gnu/packages/rdesktop.scm (xrdp): Update to 0.10.3.
[inputs]: Replace fuse-2 with fuse.
[arguments] <#:phases>: Add phase 'set-cflags-file-offset-bit-64
after 'unpack.
* gnu/packages/rdesktop.scm (xorgxrdp): Update to 0.10.4.
Change-Id: I581b8f75c25642d054bcdf22a325b67a1c47c73e
---
gnu/packages/rdesktop.scm | 18 ++++++++++++------
1 file changed, 12 insertions(+), 6 deletions(-)
base-commit: 8c43056aabc2d22da61dc86049b143f7ae1ef516
Comments
Hi, also the reason I sent the patch with the two packages upgraded
together because thy are closely related and released in close
matching versions.
On Tue, Apr 1, 2025 at 10:53 PM Andy Tai <atai@atai.org> wrote:
>
> * gnu/packages/rdesktop.scm (xrdp): Update to 0.10.3.
> [inputs]: Replace fuse-2 with fuse.
> [arguments] <#:phases>: Add phase 'set-cflags-file-offset-bit-64
> after 'unpack.
> * gnu/packages/rdesktop.scm (xorgxrdp): Update to 0.10.4.
>
Hello!
Am Wed, Apr 02, 2025 at 12:32:36AM -0700 schrieb Andy Tai:
> Hi, also the reason I sent the patch with the two packages upgraded
> together because thy are closely related and released in close
> matching versions.
They can still be sent as a patch series of two different commits,
which is a bit more annoying to do with the debbugs interface, see
https://guix.gnu.org/manual/devel/en/html_node/Sending-a-Patch-Series.html#Multiple-Patches-1
(but quite easy for a v2). Then QA handles them together.
Then they would be applied in a row with one "git push", so would also
appear together when people do a "guix pull".
Andreas
@@ -168,7 +168,7 @@ (define-public freerdp
(define-public xrdp
(package
(name "xrdp")
- (version "0.10.1")
+ (version "0.10.3")
(source (origin
(method url-fetch)
(uri (string-append
@@ -176,10 +176,10 @@ (define-public xrdp
version "/xrdp-" version ".tar.gz"))
(sha256
(base32
- "10rgc9bfharwj7bq5k4qp4x00w214h6c6f861zi301h84125ylx2"))))
+ "15nhfh8lxwf0jlmq6knh3851sp6njps9nhl8n2867il7mcr9gmsj"))))
(build-system gnu-build-system)
(inputs (list check
- fuse-2
+ fuse
imlib2
lame
libjpeg-turbo
@@ -214,7 +214,13 @@ (define-public xrdp
"--enable-pixman=yes"
"--enable-imlib2=yes"
"--enable-pam-config=unix"
- "--enable-ipv6=yes")))
+ "--enable-ipv6=yes")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-cflags-file-offset-bit-64
+ (lambda _
+ (setenv "CFLAGS"
+ "-D_FILE_OFFSET_BITS=64"))))))
(home-page "https://www.xrdp.org")
(synopsis "Remote Desktop Protocol (RDP) server")
(description
@@ -234,7 +240,7 @@ (define-public xrdp
(define-public xorgxrdp
(package
(name "xorgxrdp")
- (version "0.10.2")
+ (version "0.10.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -243,7 +249,7 @@ (define-public xorgxrdp
(file-name (git-file-name name version))
(sha256
(base32
- "1dcxn0v88426j4n7irhy6h3qb21202v5xs1vr7j8xvs3sxihc2f7"))))
+ "0y243h7mk9jy5yrdgngjkcr6rzq4116ip7pvc6vwz7yfnxxd9v2f"))))
(build-system gnu-build-system)
(inputs (list check
imlib2