diff mbox series

[bug#63866,v2,09/12] gnu: perl-specio: Update to 0.48.

Message ID 9891899135bdaf238351b2efe94e7cb9f13b660e.1722861235.git.gemmaro.dev@gmail.com
State New
Headers show
Series [bug#63866,v2,01/12] gnu: Add perl-xstring. | expand

Commit Message

gemmaro Aug. 5, 2024, 12:33 p.m. UTC
* gnu/packages/perl.scm (perl-specio): Update to 0.48.

Change-Id: I7c6dbe379fafc17a4290add9dd3bcc9b3e90acbc
---
 gnu/packages/perl.scm | 24 ++++++++++++++----------
 1 file changed, 14 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fa546b101c..ddf3128ac7 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9659,7 +9659,7 @@  (define-public perl-sort-naturally
 (define-public perl-specio
   (package
     (name "perl-specio")
-    (version "0.38")
+    (version "0.48")
     (source
      (origin
        (method url-fetch)
@@ -9667,25 +9667,29 @@  (define-public perl-specio
                            "Specio-" version ".tar.gz"))
        (sha256
         (base32
-         "1s5xd9awwrzc94ymimjkxqs6jq513wwlmwwarxaklvg2hk4lps0l"))))
+         "1cl22s0z00jj4nlaz9yfmhi7pxq1s4qr21vkh7q4w9zih0spk18c"))))
     (build-system perl-build-system)
+    (native-inputs (list perl-test-needs perl-moose perl-moo perl-namespace-autoclean))
     (propagated-inputs
      (list perl-devel-stacktrace
            perl-eval-closure
            perl-module-runtime
            perl-mro-compat
-           perl-role-tiny
+           perl-ref-util
+           perl-role-tiny-2
+           perl-sub-quote
            perl-test-fatal
-           perl-test-needs))
+           perl-try-tiny
+           perl-xstring))
     (home-page "https://metacpan.org/release/Specio")
     (synopsis "Classes for representing type constraints and coercion")
     (description "The Specio distribution provides classes for representing type
-constraints and coercion, along with syntax sugar for declaring them.  Note that
-this is not a proper type system for Perl. Nothing in this distribution will
-magically make the Perl interpreter start checking a value's type on assignment
-to a variable. In fact, there's no built-in way to apply a type to a variable at
-all.  Instead, you can explicitly check a value against a type, and optionally
-coerce values to that type.")
+constraints and coercion, along with syntax sugar for declaring them.  Note that this
+is not a proper type system for Perl.  Nothing in this distribution will magically
+make the Perl interpreter start checking a value's type on assignment to a variable.
+In fact, there's no built-in way to apply a type to a variable at all.  Instead, you
+can explicitly check a value against a type, and optionally coerce values to that
+type.")
     (license license:artistic2.0)))
 
 (define-public perl-spiffy