diff mbox series

[bug#56721] gnu: Add font-chiron-hei-hk

Message ID 981e35516ee5d3b9d7a38e1cdaf7760b81efb6ac.1658563372.git.hako@ultrarare.space
State Accepted
Headers show
Series [bug#56721] gnu: Add font-chiron-hei-hk | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain July 23, 2022, 8:01 a.m. UTC
* gnu/packages/fonts (font-chiron-hei-hk): New variable.

Signed-off-by: Hilton Chain <hako@ultrarare.space>
---
 gnu/packages/fonts.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

--
2.36.1

Comments

Hilton Chain Aug. 3, 2022, 7:04 a.m. UTC | #1
Continues at #56904.
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index c60640a757..5b5da013f2 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2767,3 +2767,21 @@  (define-public font-chiron-sung-hk
      "Chiron Sung HK (昭源宋體) is a Traditional Chinese serif
  typeface based on Adobe’s Source Han Serif (a.k.a. Google’s Noto Sans CJK).")
     (license license:silofl1.1)))
+
+(define-public font-chiron-hei-hk
+  (package
+    (name "font-chiron-hei-hk")
+    (version "2.502")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/chiron-fonts/chiron-hei-hk/archive/refs/tags/v"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0d9r9wd5ssiihiywpybr9zzq3gca2678si09jz7c3mniash278ym"))))
+    (build-system font-build-system)
+    (home-page "https://chiron-fonts.github.io/")
+    (synopsis "昭源黑體")
+    (description "The complementary sans-serif typeface for Chiron Sung HK.")
+    (license license:silofl1.1)))