diff mbox series

[bug#53779,1/5] gnu: iwd: Remove input labels.

Message ID 97c63d45240ce29586d92a4b90e6eff3aecf9284.1643988584.git.simon@simonsouth.net
State Accepted
Headers show
Series gnu: iwd: Build from Git; update to 1.23. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon South Feb. 4, 2022, 3:43 p.m. UTC
* gnu/packages/networking.scm (iwd)[native-inputs]: Remove input labels.
---
 gnu/packages/networking.scm | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

Comments

M Feb. 6, 2022, 10:07 a.m. UTC | #1
Simon South schreef op vr 04-02-2022 om 10:43 [-0500]:
> +     (list pkg-config python python-docutils openssl))
>      (arguments
>       `(#:configure-flags
>         (let ((dbus (assoc-ref %outputs "out")))

While you're at it, could you remove the %outputs that is being phased
out in favour of the G-exp equivalent?

  #:configure-flags
  ,#~(let ((dbus #$output))
       ...)

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3aa3e9b8e9..064248600e 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3581,10 +3581,7 @@  (define-public iwd
     (inputs
      (list dbus ell readline))
     (native-inputs
-     `(("pkgconfig" ,pkg-config)
-       ("python" ,python)
-       ("rst2man" ,python-docutils)
-       ("openssl" ,openssl)))
+     (list pkg-config python python-docutils openssl))
     (arguments
      `(#:configure-flags
        (let ((dbus (assoc-ref %outputs "out")))