diff mbox series

[bug#68061] gnu: python-markdown-it-py: Update to 3.0.0.

Message ID 97a93518fa3e157454370f65d049347051ee27fa.1703691924.git.felgru@posteo.net
State New
Headers show
Series [bug#68061] gnu: python-markdown-it-py: Update to 3.0.0. | expand

Commit Message

Felix Gruber Dec. 27, 2023, 3:45 p.m. UTC
* gnu/packages/python-xyz.scm (python-markdown-it-py): Update to 3.0.0.
[propagated-inputs]: Remove python-typing-extensions; add python-commonmark,
python-linkify-it-py, python-markdown, python-mistletoe,
python-mistune, python-panflute, python-psutil, and python-pyyaml.
[native-inputs]: Remove python-flit; add python-flit-core.

Change-Id: I5dc06b163ddbec0a32a9d7c3da2c834b2e74cd74
---
 gnu/packages/python-xyz.scm | 17 ++++++++++++-----
 1 file changed, 12 insertions(+), 5 deletions(-)


base-commit: 8f03a51f5cdf4015d22a42e0796aad28f092e40b
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cab44be011..2575f304ab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5482,19 +5482,26 @@  (define-public python-makefun
 (define-public python-markdown-it-py
   (package
     (name "python-markdown-it-py")
-    (version "2.1.0")
+    (version "3.0.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "markdown-it-py" version))
               (sha256
                (base32
-                "1nh75i72584r70alhqc479gys04s5m5g3vq601yf2njbs7z5jzng"))))
+                "1swgvyiavak0nmfb31lq5zck5chwhmyf6qb6qwpcav86zaa0mxp3"))))
     (build-system pyproject-build-system)
     (arguments (list #:tests? #f))      ;pypi source does not contains tests
-    (native-inputs (list python-flit))
+    (native-inputs (list python-flit-core))
     (propagated-inputs
-     (list python-mdurl
-           python-typing-extensions))
+     (list python-commonmark
+           python-linkify-it-py
+           python-markdown
+           python-mdurl
+           python-mistletoe
+           python-mistune
+           python-panflute
+           python-psutil
+           python-pyyaml))
     (home-page "https://github.com/executablebooks/markdown-it-py")
     (synopsis "Python port of markdown-it")
     (description