diff mbox series

[bug#40165] Subject: [PATCH] gnu: Add python-flask-markdown.

Message ID 978aeda27a795fd06ef7fb77049adbe8@airmail.cc
State Accepted
Headers show
Series [bug#40165] Subject: [PATCH] gnu: Add python-flask-markdown. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

pinoaffe March 21, 2020, 8:06 a.m. UTC
* gnu/packages/python-web.scm (python-flask-markdown): New variable.
---
  gnu/packages/python-web.scm | 30 ++++++++++++++++++++++++++++++
  1 file changed, 30 insertions(+)

      (name "python-html5lib")

Comments

Marius Bakke March 29, 2020, 8:07 p.m. UTC | #1
pinoaffe@airmail.cc writes:

> * gnu/packages/python-web.scm (python-flask-markdown): New variable.

Thanks!

[...]

> +(define-public python-flask-markdown
> +  (package
> +    (name "python-flask-markdown")
> +    (version "0.3")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (pypi-uri "Flask-Markdown" version))
> +        (sha256
> +          (base32
> +            "0l32ikv4f7va926jlq4f7gx0xid247bhlxl6bd9av5dk8ljz1hyq"))))
> +    (build-system python-build-system)
> +    (arguments
> +       `(#:tests? #f))

Can you add a comment about why tests are disabled?

> +    (propagated-inputs
> +      `(("python-markdown" ,python-markdown)
> +        ("python-flask" ,python-flask)))
> +    (native-inputs
> +      `(("python-nose" ,python-nose)))
> +    (home-page
> +      "http://github.com/dcolish/flask-markdown")
> +    (synopsis
> +      "Small extension to make using markdown in flask easy")
> +    (description
> +      "Small extension to make using markdown in flask easy")

Can you expand on the description a bit?  Being identical to the
synopsis is not very helpful for interested readers.

Please also adjust the indentation of the whole package.  If you are not
using Emacs you can use the ./etc/indent-code.el script.

Can you send an updated patch?  Thanks in advance!
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b02ffd5f58..db66f1ed4d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -470,6 +470,36 @@  both of which are installed automatically if you 
install this library.")
  (define-public python2-flask-babel
    (package-with-python2 python-flask-babel))

+(define-public python-flask-markdown
+  (package
+    (name "python-flask-markdown")
+    (version "0.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "Flask-Markdown" version))
+        (sha256
+          (base32
+            "0l32ikv4f7va926jlq4f7gx0xid247bhlxl6bd9av5dk8ljz1hyq"))))
+    (build-system python-build-system)
+    (arguments
+       `(#:tests? #f))
+    (propagated-inputs
+      `(("python-markdown" ,python-markdown)
+        ("python-flask" ,python-flask)))
+    (native-inputs
+      `(("python-nose" ,python-nose)))
+    (home-page
+      "http://github.com/dcolish/flask-markdown")
+    (synopsis
+      "Small extension to make using markdown in flask easy")
+    (description
+      "Small extension to make using markdown in flask easy")
+    (license license:bsd-3)))
+
+(define-public python2-flask-markdown
+  (package-with-python2 python-flask-markdown))
+
  (define-public python-html5lib
    (package