diff mbox series

[bug#64486,08/22] gnu: Add perl-array-intspan.

Message ID 976d4f95c04167bfb85255d102b17a062c1e29ea.1688625768.git.mirai@makinata.eu
State New
Headers show
Series Update licensecheck to 3.3.9. | expand

Commit Message

Bruno Victal July 6, 2023, 6:42 a.m. UTC
* gnu/packages/perl.scm (perl-array-intspan): New variable.
---
 gnu/packages/perl.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 191f6c0df3..84f6b0ac67 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -642,6 +642,27 @@  (define-public perl-appconfig
 configuration files and parsing command line arguments.")
     (license (package-license perl))))
 
+(define-public perl-array-intspan
+  (package
+    (name "perl-array-intspan")
+    (version "2.004")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/D/DD/DDUMONT/Array-IntSpan-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "168crsh363lgh2s127hnrbda37wvcq36xpcv59mywm89rspigkad"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/Array-IntSpan")
+    (synopsis "Handle arrays of scalars or objects using integer ranges")
+    (description "This module brings the speed advantages of
+@code{Set::IntSpan} (written by Steven McDougall) to arrays.  Uses include
+manipulating grades, routing tables, or any other situation where you have
+mutually exclusive ranges of integers that map to given values.")
+    (license license:artistic2.0)))
+
 (define-public perl-array-utils
   (package
     (name "perl-array-utils")