diff mbox series

[bug#44984] gnu: electrum: Update to 4.0.5.

Message ID 976b54a9e8d7912782a423134dd3151b029ec5f0.camel@free.fr
State Accepted
Headers show
Series [bug#44984] gnu: electrum: Update to 4.0.5. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

dftxbs3e Dec. 1, 2020, 8:58 a.m. UTC
Hello!

I attached all patches generated by git format-patch. They are numbered
in the order they must be applied, I hope that will be OK.

Thank you!

Comments

dftxbs3e Dec. 1, 2020, 9:34 a.m. UTC | #1
close 44984

I could not apply the patches using git am when downloading the mbox
file from issues.guix.gnu.org. I am looking into git send-email,
however sending more patches here will get dirty. Closing and I will
create another issue. Sorry for that.
diff mbox series

Patch

From 5d439ae49ae55abf5c8e908032ffb405c1cbc1ba Mon Sep 17 00:00:00 2001
From: John Doe <dftxbs3e@free.fr>
Date: Tue, 1 Dec 2020 07:27:54 +0100
Subject: [PATCH 1/7] gnu: Add python-helpdev.

* gnu/packages/python-xyz.scm (python-helpdev): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ad51498050..36373ae71c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23256,3 +23256,25 @@  process.")
     (description
       "Provides an abstraction layer on top of the various Qt bindings (PyQt5, PyQt4 and PySide) and additional custom QWidgets.")
     (license license:expat)))
+
+(define-public python-helpdev
+  (package
+    (name "python-helpdev")
+    (version "0.7.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "helpdev" version))
+        (sha256
+          (base32
+            "0gfvj28i82va7c264jl2p4cdsl3lpf9fpb9cyjnis55crfdafqmv"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-importlib-metadata"
+         ,python-importlib-metadata)))
+    (home-page "https://gitlab.com/dpizetta/helpdev")
+    (synopsis
+      "HelpDev - Extracts information about the Python environment easily.")
+    (description
+      "HelpDev - Extracts information about the Python environment easily.")
+    (license license:expat)))
-- 
2.28.0