[bug#75167,gnome-team,5/6] gnu: Add libspelling.

Message ID 976552011b3d876652af1d401b4f1c8cddfb7d84.1735418244.git.liliana.prikler@gmail.com
State New
Headers
Series Update GNOME Builder to 47.2 |

Commit Message

Liliana Marie Prikler Dec. 28, 2024, 8:34 p.m. UTC
  * gnu/packages/gnome.scm (libspelling): New variable.
---
 gnu/packages/gnome.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
  

Comments

Maxim Cournoyer Dec. 29, 2024, 4:34 a.m. UTC | #1
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/gnome.scm (libspelling): New variable.
> ---
>  gnu/packages/gnome.scm | 34 ++++++++++++++++++++++++++++++++++
>  1 file changed, 34 insertions(+)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index fea67718c37..f3568350f79 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -13612,6 +13612,40 @@ (define-public sysprof-3.44
>                              (("gtk-update-icon-cache") "true")
>                              (("update-desktop-database") "true"))))))))))
>  
> +(define-public libspelling
> +  (package
> +    (name "libspelling")
> +    (version "0.4.5")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://gitlab.gnome.org/GNOME/libspelling")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32 "030s821sb9rsr1ysl79x7id1bsin9idy8z7p85qr9cvw1w3f2s7r"))))
> +    (build-system meson-build-system)
> +    (arguments
> +     (list #:phases
> +           #~(modify-phases %standard-phases
> +               (add-before 'check 'setup-home
> +                 (lambda _
> +                   ;; Tests require a writable HOME.
> +                   (setenv "HOME" (getcwd)))))))
> +    (inputs (list enchant gtk gtksourceview sysprof))
> +    (native-inputs
> +     (list gobject-introspection
> +           gi-docgen
> +           pkg-config
> +           vala

Please sort.

> +           ;; For testing

Please properly punctuate line comments (here, by adding trailing '.').

> +           aspell aspell-dict-en))
> +    (home-page "https://gitlab.gnome.org/GNOME/libspelling/")
> +    (synopsis "Spell-checking library for GTK 4")
> +    (description "This package provides a spell-checker for
> +GtkTextView widgets.")
> +    (license license:lgpl2.1+)))

Other than these two nitpicks, LGTM.
  

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fea67718c37..f3568350f79 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13612,6 +13612,40 @@  (define-public sysprof-3.44
                             (("gtk-update-icon-cache") "true")
                             (("update-desktop-database") "true"))))))))))
 
+(define-public libspelling
+  (package
+    (name "libspelling")
+    (version "0.4.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.gnome.org/GNOME/libspelling")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "030s821sb9rsr1ysl79x7id1bsin9idy8z7p85qr9cvw1w3f2s7r"))))
+    (build-system meson-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'setup-home
+                 (lambda _
+                   ;; Tests require a writable HOME.
+                   (setenv "HOME" (getcwd)))))))
+    (inputs (list enchant gtk gtksourceview sysprof))
+    (native-inputs
+     (list gobject-introspection
+           gi-docgen
+           pkg-config
+           vala
+           ;; For testing
+           aspell aspell-dict-en))
+    (home-page "https://gitlab.gnome.org/GNOME/libspelling/")
+    (synopsis "Spell-checking library for GTK 4")
+    (description "This package provides a spell-checker for
+GtkTextView widgets.")
+    (license license:lgpl2.1+)))
+
 (define-public gnome-builder
   (package
     (name "gnome-builder")