[bug#75989] gnu: Add mc2mt-cpp.

Message ID 9749c831-5b2c-448a-8c98-10eee274b446@disroot.org
State New
Headers
Series [bug#75989] gnu: Add mc2mt-cpp. |

Commit Message

Adam Faiz Feb. 1, 2025, 9:45 a.m. UTC
  From d4c0e54e420eaf5937266310b42e9addf6528903 Mon Sep 17 00:00:00 2001
Message-ID: <d4c0e54e420eaf5937266310b42e9addf6528903.1738402724.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sat, 1 Feb 2025 17:35:49 +0800
Subject: [PATCH] gnu: Add mc2mt-cpp.

* gnu/packages/game-development.scm (mc2mt-cpp): New variable.
---
 gnu/packages/game-development.scm | 32 +++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: ba0340eec2e50439cfd94e85b40bf41c2d488a74
  

Comments

Liliana Marie Prikler Feb. 1, 2025, 9:48 a.m. UTC | #1
Am Samstag, dem 01.02.2025 um 17:45 +0800 schrieb Adam Faiz:
> From d4c0e54e420eaf5937266310b42e9addf6528903 Mon Sep 17 00:00:00
> 2001
> Message-ID:
> <d4c0e54e420eaf5937266310b42e9addf6528903.1738402724.git.adam.faiz@di
> sroot.org>
> From: AwesomeAdam54321 <adam.faiz@disroot.org>
> Date: Sat, 1 Feb 2025 17:35:49 +0800
> Subject: [PATCH] gnu: Add mc2mt-cpp.
> 
> * gnu/packages/game-development.scm (mc2mt-cpp): New variable.
Why the suffix -cpp?


Lexically LGTM.

Cheers
  
Adam Faiz Feb. 1, 2025, 10:52 a.m. UTC | #2
On 2/1/25 17:48, Liliana Marie Prikler wrote:
> Am Samstag, dem 01.02.2025 um 17:45 +0800 schrieb Adam Faiz:
>> From d4c0e54e420eaf5937266310b42e9addf6528903 Mon Sep 17 00:00:00
>> 2001
>> Message-ID:
>> <d4c0e54e420eaf5937266310b42e9addf6528903.1738402724.git.adam.faiz@di
>> sroot.org>
>> From: AwesomeAdam54321 <adam.faiz@disroot.org>
>> Date: Sat, 1 Feb 2025 17:35:49 +0800
>> Subject: [PATCH] gnu: Add mc2mt-cpp.
>>
>> * gnu/packages/game-development.scm (mc2mt-cpp): New variable.
> Why the suffix -cpp?

I added the suffix -cpp so that it won't conflict with my previous submission for a very similiar package:
https://issues.guix.gnu.org/64362

> 
> Lexically LGTM.
> 
> Cheers
  

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 57cebedda8..8cd3a0a3ee 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2004,6 +2004,38 @@  (define-public mc2mt
     (home-page "https://github.com/listia/mc2mt")
     (license license:expat))))
 
+(define-public mc2mt-cpp
+  (let ((commit "4ee1e76643e6ad98ede07e1a92378a057c4e9851")
+        (revision "0"))
+  (package
+    (name "mc2mt-cpp")
+    (version (git-version "0.1" revision commit))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rollerozxa/MC2MT")
+             (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0by6pnpp1bq0akq4s9r6v0jc5s4ywxi9ysvlg845rbd0vpam075k"))))
+    (build-system cmake-build-system)
+    (inputs (list sqlite zlib))
+    (arguments
+     (list
+      #:tests? #f ; no tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'install
+            (lambda _
+              (install-file "bin/MC2MT"
+                            (string-append #$output "/bin")))))))
+    (synopsis "Minecraft to Minetest world converter")
+    (description "@code{MC2MT} is a Minecraft to Minetest world converter.
+It can convert worlds from Minecraft 1.12 and below.")
+    (home-page "https://github.com/rollerozxa/MC2MT")
+    (license license:lgpl2.1+))))
+
 (define-public mygui
   (package
     (name "mygui")