diff mbox series

[bug#39393] gnu: cairo: Add support for XML.

Message ID 97363e37d63fb27890143dd9ffbd37f7c2e9b5d0.camel@zrythm.org
State Accepted
Headers show
Series [bug#39393] gnu: cairo: Add support for XML. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Feb. 2, 2020, 4:35 p.m. UTC
Hi,

This patch adds support for XML surfaces in cairo. It is needed when
using this for example:
https://github.com/tyronx/svg2cairo

It does not seem to require any additional dependencies so I don't see
a reason not to include it by default.

Thanks,
Alex

Comments

Marius Bakke Feb. 14, 2020, 6:21 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> Hi,
>
> This patch adds support for XML surfaces in cairo. It is needed when
> using this for example:
> https://github.com/tyronx/svg2cairo
>
> It does not seem to require any additional dependencies so I don't see
> a reason not to include it by default.

Thanks!  I pushed it to the 'core-updates' branch in
bbd1e4e7ed0d6d2ff23f3bedd94641d5ad527d3e, because it triggers a rebuild
of more than 4000 packages (see guix refresh -l cairo).
diff mbox series

Patch

From 33a5d3fab78c92ef5af0615b7e17acacc792d225 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sun, 2 Feb 2020 16:26:44 +0000
Subject: [PATCH] gnu: cairo: Add support for XML.

* gnu/packages/gtk.scm (cairo): Add enable-xml flag.
---
 gnu/packages/gtk.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f934eabe27..3924f6b122 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -146,7 +146,9 @@  tools have full access to view and control running applications.")
       ("python" ,python-wrapper)))
     (arguments
      `(#:tests? #f  ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
-       #:configure-flags '("--enable-tee")))  ; needed for GNU Icecat
+       #:configure-flags
+         '("--enable-tee"  ; needed for GNU Icecat
+           "--enable-xml")))  ; for cairo-xml support
    (synopsis "2D graphics library")
    (description
     "Cairo is a 2D graphics library with support for multiple output devices.
-- 
2.25.0