[bug#76067,v2] gnu: Add crow-translate.
Commit Message
From: Junker <dk@junkeria.club>
* gnu/packages/kde.scm (crow-translate): New variable.
Change-Id: I119646d76cd228fb21227dde14bbe2f5571804ce
---
gnu/packages/kde.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
base-commit: 73d74032d580212e7b59644d3324677926e4339b
@@ -20,6 +20,7 @@
;;; Copyright © 2023 Mehmet Tekman <mtekman89@gmail.com>
;;; Copyright © 2024 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2025 Sughosha <sughosha@disroot.org>
+;;; Copyright © 2025 Junker <dk@junkeria.club>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -94,6 +95,7 @@ (define-module (gnu packages kde)
#:use-module (gnu packages markup)
#:use-module (gnu packages maths)
#:use-module (gnu packages mp3)
+ #:use-module (gnu packages ocr)
#:use-module (gnu packages onc-rpc)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
@@ -141,6 +143,39 @@ (define-public baloo-widgets
This package contains GUI widgets for baloo.")
(license license:lgpl2.0+)))
+(define-public crow-translate
+ (package
+ (name "crow-translate")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/crow-translate/" version
+ "/crow-translate-v" version ".tar.gz"))
+ (sha256
+ (base32 "18f7i5sxrvqp6h7zj77sdxyy9rlbw0rv3w7akf1j14072ala9bwc"))))
+ (build-system qt-build-system)
+ (arguments '(#:tests? #f)) ; there are no tests.
+ (inputs
+ (list qtbase-5
+ qtx11extras
+ qtsvg-5
+ qtmultimedia-5
+ tesseract-ocr
+ kwayland-5))
+ (native-inputs
+ (list pkg-config
+ extra-cmake-modules
+ qttools-5))
+ (home-page "https://invent.kde.org/office/crow-translate")
+ (synopsis "Application that allows you to translate and speak text")
+ (description
+ "Application written in C++/Qt that allows you to translate and speak text
+using Mozhi.")
+ (license (list license:gpl3+
+ license:cc0
+ license:cc-by-sa4.0))))
+
(define-public futuresql
(package
(name "futuresql")