diff mbox series

[bug#73342,2/4] gnu: Add tinycmmc.

Message ID 96f9341e716818415946967bdc2b83c2a24b7588.1726707755.git.maxim.cournoyer@gmail.com
State New
Headers show
Series [bug#73341,1/4] services: Extend udev rules in joycond-service-type. | expand

Commit Message

Maxim Cournoyer Sept. 19, 2024, 1:02 a.m. UTC
* gnu/packages/cmake.scm (tinycmmc): New variable.

Change-Id: Ie3a4e04f1ab3fb3ad6b6825f371d233a4ee905e2
---
 gnu/packages/cmake.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index ac75321937..0a9e5ba907 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -499,3 +499,24 @@  (define-public qmsetup
 @item Support calling Qt Linguist Tools via CMake conveniently
 @end itemize")
       (license license:expat))))
+
+(define-public tinycmmc
+  (package
+    (name "tinycmmc")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Grumbel/tinycmmc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0chv7h6vnd8zpa6b69krxwdgvp3n5fd37355wa1zwi14x4nyyay5"))))
+    (build-system cmake-build-system)
+    (arguments (list #:tests? #f))      ;no test suite
+    (home-page "https://github.com/Grumbel/tinycmmc")
+    (synopsis "Tiny CMake Module Collections")
+    (description "The tinycmmc package contains a small collection of reusable
+CMake modules.")
+    (license license:zlib)))